I am trying to setup rTorrent to seed some torrents for longer than the default, if these torrents are loaded from a watch directory. The problem is that rTorrent seems to be stopping these torrents as soon as the default seeding ratio is reached.

Extracts from my .rtorrent.rc

Default Seeding ratio


Setting up view/group for torrents loaded from watch directory

view.add = view_group_2
view.persistent = view_group_2
group.insert = group_2, view_group_2
method.set = group.group_2.ratio.command, d.close=

Watch directory configuration

schedule = watch_directory_3,10,10,"load.start_verbose=/home/avggeek/torrent_downloads/import/hipvt_tracker/movies/*.torrent, view.set_visible=view_group_2, d.custom1.set=/home/avggeek/torrent_downloads/completed/movies/"

I then added a torrent to the watch directory

Torrent file in watch directory

But after the torrent exceeded the default minimum ratio, rTorrent "Closed" the torrent:

enter image description here

Thinking it to be a sequencing issue, I have the default seeding commands placed first, followed by the custom view commands and then the watch directory. However, this does not seem to make any difference. Any suggestions on what I should do?

I am running rTorrent 0.9.2/libtorrent 0.13.2 compiled from source (with Pyroscope's patches applied) on Debian/Squeeze.

rtcontrol --from-view started metafile=//hipvt_tracker/movies// \
    [ ratio=+4 OR completed=+5d ] --close --cron --yes

That would work. ;)

  • I assume to use this approach, I would have to disable all ratio commands in rtorrent.rc? If so, could you help me understand how to implement the default ratio in rtcontrol i.e., stop seeding between 2.0 and 2.1 for torrents not loaded via watch directories? – avggeek Feb 6 '13 at 5:56
  • Depends on a few details, but generally "metafile=\!//watch//" with the ratio conditions added (i.e. similar to above command) would work. Pack all your rules into a bash script, and start that regularly via cron. – pyroscope Feb 7 '13 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.