8

I see Notepad adds .txt to the save name I choose. I can change this by changing file type when saving. But, next time I must change the file type again. How do I choose the default file type?

I see that my type is "Normal Text" in the Settings > Preferences. But, I see no "None" option there.

4
  • 2
    It bugs me too that a potentially powerful code editor makes the small things so annoying. Seriously: Who writes so many *.txt files?
    – Domi
    Apr 22, 2014 at 9:33
  • I have Notepad++ v6.8.6 and I seem to have the opposite problem: it no longer saves to the default extension. If I save to filename "test" then Notepad++ no longer adds the ".txt" extension. This is very annoying as it requires me to constantly add the extension manually. Feb 8, 2016 at 16:01
  • @Domi I write so many text files! :) Several per day at least. I like using Notepad++ for writing meeting minutes Feb 8, 2016 at 16:02
  • Ok, I just confirmed that my related problem in Notepad++ v6.8.6 (".txt" extension not being added by default) is a bug introduced in that version only. The bug gets fixed in v6.8.7 notepad-plus-plus.org/download/v6.8.7.html "2. Restore file extension feature in save dialog." Feb 9, 2016 at 13:06

5 Answers 5

8

I found a workaround here.

You have to edit langs.xml. On Windows, it is located in %appdata%\notepad++. Change < Language name="normal" ext="txt"/> to < Language name="normal" ext=""/>. Then set your default language to Normal Text.

Alternately, you could change a language you don't use if you wish to keep Normal Text for .txt files. I chose makefile because I don't use it and there is only one setting for # comments.

1
  • FYI, the link in this answer doesn't work.
    – Math1000
    Mar 21, 2018 at 15:58
1

If you are wanting to save a file with a default extension of let's say, .c , everytime you use notepad++. You go into Settings -> Preferences -> File Association -> click C, C++,obj in Supported exts: -> click .c -> press the (->) button o put it into Registered exts: . You now will by default first choice, save as a .c file

1

In Notepad++ 7.1 From the menu, select:

Settings | Preferences | Default Directory. Place a check-mark in the "Use new style save dialog.

When you save a file, manually add the file extension to control how the file is saved (file type).

0

None of the options above worked for me, but this did:-

Settings -> Preferences -> MISC. Then click Set Save dialog file extension to . instead of .txt for Normal Text*.

And then you add the extension you want. I use a lot of .bib (BibTeX) files.

0

This works on both 7.9.1 (32-bit) and 7.9.3 (64-bit) Windows 10 and Windows 7 respectively for me.

GOTO Settings -> Preferences -> New Document -> Default language: PHP (for instance)

2
  • Reread the question, they want no extension.
    – Toto
    Mar 24, 2021 at 19:21
  • Welcome to Super User! Before answering an old question having an accepted answer (look for green ✓) as well as other answers ensure your answer adds something new or is otherwise helpful in relation to them. Here is a guide on How to Answer. There is also tour for the site tour, and help center for the help center. Mar 25, 2021 at 11:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .