Normally, plugging in the Arduino to a Mac creates /dev/tty.usbmodemXXXX but on Mac OS X 10.8 (Mountain Lion) it does not. How can I get this operating system to see the device?

migrated from electronics.stackexchange.com Feb 5 '13 at 18:58

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.


Many sources that come up in Google searches say that you don't need to install the FTDI drivers for newer Arduinos (Since the Uno or Mega). If you have an Arduino Mega this may lead you to believe you don't need them. However, some older revisions of the Arduino Mega do in fact need these drivers, so if you don't see the device in /dev/tty.usbmodemXXXX try installing the FTDI drivers.

Get the latest drivers from here: http://www.ftdichip.com/Drivers/VCP.htm

  • 3
    The newer Arduinos don't have FTDI devices on them, so this would not help. Arduinos now use an ATmega16U2 as the USB-serial IC. – Fake Name Jan 20 '13 at 4:57
  • Well installing it worked for my Arduino Mega. According to the sources I read from Google searches Uno and Mega don't need this, but I did for my Mega, so I generalised them together. How can I improve the answer to be more accurate? If the Uno doesn't need it but the Mega does, maybe just removing the Uno will make it right? Or are there multiple versions of the Mega, some which need it and others which don't? – jhabbott Jan 21 '13 at 11:11
  • You probably have an older Mega. They used to use a FTDI device, and I don't think they've changed the Mega name, despite the board revisions. – Fake Name Jan 21 '13 at 11:49
  • Ok, I've edited that in. Thanks for helping to improve the answer. – jhabbott Jan 21 '13 at 12:04
  • From browsing the arduino site, It turns out there are a bunch of versions of the "Arduino Mega". There is the Arduino Mega, the Arduino Mega 2560, the Arduino Mega 2560 R3, etc... Their naming scheme sucks. – Fake Name Jan 21 '13 at 12:38

I just went through this on my OS X 10.8 machine. I did in fact need to install the drivers you mentioned for my Arduino Nano but not for my Uno 3. A quick re-launch of the Arduino IDE caused the Nano to show up in the list.


I've experienced inconsistent connections to a Due board with OS X 10.8.2 when using a single USB cable to supply power and communications. You might try using a second USB connection on boards that support it or an external power supply.


There is something fishy with how the Due interacts with OSX. You can get it to work by pressing the erase button between sketch downloads:


  • 1
    Welcome to Super User! Generally we like answers on the site to be able to stand on their own - Links are great, but if that link ever breaks the answer should have enough information to still be helpful. Please consider editing your answer to include more detail. See the FAQ for more info. – slm Apr 4 '13 at 13:39

Downloading these drivers worked for me:


My Arduino Mega 2560 was actually a MultiWii PRO Flight Controller from Hobby King.

Although the clock speed seems to be off a little.


I have an Osepp Uno R3 Plus. Although it's an Uno, it uses the FTDI chip, so installing the FTDI driver was what it needed.


I've manage to see /dev/tty.usbserial-* after installing above mentioned FTDI driver http://www.ftdichip.com/Drivers/VCP.htm. This is on MacOS 10.8.5, Arduino IDE 1.0.5, and Arduino Mega with ARMEGA1289 16AU 0849 chip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.