46

I use alt+tab all day long to switch between windows. When I'm working remotely, I'll use Remote Desktop to log in to my Windows 7 PC at work.

From the host machine, it's simple to alt+tab to switch to get to the remote machine.

However, on the remote machine, alt+tab doesn't allow me to switch back to the host machine, forcing me to use the mouse (gasp!). To be clear, I still want to see the guest machine's applications when I use alt+tab on the guest machine. I just want to be able to see the host machine as one of the options in alt+tab while I'm remoted in.

Is there a way to be able to alt+tab back to the host machine from the remote machine, perhaps via a 3rd-party add-on?

  • 4
    Is this option set? – Karan Feb 5 '13 at 19:57
  • @Karan it's set to "Only when using the full screen," which is actually what I want. I still want to be able to use Alt+Tab on the guest machine, but I want to the host machine to show up as an option under Alt+Tab. Question updated accordingly. – Ben McCormack Feb 5 '13 at 21:09

12 Answers 12

35

Use ctrl+alt+break to restore the Remote Desktop window, so it is no longer full screen.

Then use alt+tab to switch between applications on the local machine.

When you want to go back to the remote machine, alt+tab to it, and press ctrl+alt+break to restore it to full screen again.

  • 6
    Worked for me. For those who don't have a Pause / Break key on their laptop, do a quick search, e.g. "ThinkPad Break Key". I learned that on my ThinkPad T530, I'd have to press Fn + Alt + B to send the equivalent of a Ctrl + Alt + Break. For some reason, using AutoHotkey to send ^!{CtrlBreak} (and many other combinations) didn't work for me—many others experience the same, though AHK did seem to work for some. – Andrew Cheong Dec 26 '14 at 9:27
  • More ThinkPad specifics - for my Yoga I need Fn + Ctrl + Alt + P to emulate Ctrl + Alt + Break – Non person Jun 24 '16 at 14:09
  • 2
    To make it fullscreen again Windows + Up Arrow – Kolob Canyon Feb 9 '17 at 18:48
  • For those of you that don't have the Break key on your keyboard, see my answer – Kolob Canyon Oct 3 '18 at 17:33
25

On my system (using windows server 2012 R2), I use ctrl+alt+home to get to the remote desktop bar and then alt+tab to move around the windows on local machine.

  • 1
    This is the best solution if you want to keep alt-tab working on the remote machine, but want to also be able to switch to local machine quickly. – WiredIn Jan 25 '16 at 14:34
  • It doesn't work for me (I'm on Win7). Ctrl+Alt+break works though. – sashoalm Sep 13 '16 at 10:38
  • 1
    @sashoalm It works on win7, but it "switches back" after a second. To work, I have to use: ctrl-alt-home, tab (and maybe another tab), then alt-tab. – David Balažic Oct 17 '16 at 15:41
  • 2
    This works to "get out" of the remote desktop session, but how do I get back in? When I alt-tab back, the session isn't capturing any keyboard input anymore, and the bar isn't in focus, so hitting esc to go back does nothing anymore. – Alex Jan 5 '18 at 7:40
  • @Alex You just do Ctrl-Alt-Home again if it doesn't time out on its own. – Paul Stelian Aug 22 at 20:57
19

Alt-Insert works in windowed mode, and is almost the same as Alt-Tab.

Alt-PgDown and Alt-PgUp are also useful.

  • 1
    Handy, but how does this get back to the open windows on the local machine? It only switches between windows on the remote machine. – Garrulinae Mar 14 '14 at 8:48
  • 1
    You won't see a combined list, but if you Alt-tab for local, those others for remote, you can avoid the mouse entirely. – Nik Mar 14 '14 at 12:16
  • 1
    Thanks for providing info for those of us that run RDC mostly in windowed mode. – Adam Nofsinger Dec 31 '15 at 17:43
  • Inside options->Local Resources->Keyboard settings, Set the option to "on the remote computer" from the drop-down menu. Now you can Alt-Tab between the local machine and the remote machine using Alt + Tab and you can alternate between the remote windows using Alt-Insert shortcut suggested by Nik. – Ghos3t Mar 27 '17 at 10:45
6

Well the Solution is here - Under Remote connectivity terminal (mstsc),Navigate to third tab

"Local Resources" and Select the first dropdown - Keyboard - "On this computer" This is amazing one and make your work much easier and further can switch between host computer and remote comp (in full screen mode)

But could not navigate into remote machine so in case revert the previous settings of dropdown to old menu and use the shortcut to switch between full screen mode and normal mode of remote PC - Control + Alt + Break.

4

For me following scenario worked properly "Local Resources" and Select the first dropdown - Keyboard - "On this computer" Afterwords you should use Alt+PageUp instead of Alt+Tab

  • This worked for me, is not the best solution but solve part of the problem. – Diego Mendes Jan 16 '17 at 11:56
1

This can be done with one keypress by using autohotkey.

Capslock::                              ; replace by ^Capslock to use Control+Capslock
    WinGet, id, List,,, Program Manager
    Loop, %id%
    {
        this_id := id%A_Index%
        WinActivate, ahk_id %this_id%
        WinGetTitle, this_title, ahk_id %this_id%
        if(this_title!="")
            break
    }
    WinActivate, ahk_id %this_id%
    Send, {Alt Down}{Tab}{Alt Up}
Return

The script above will alt-tab to the host computer whenever you press caps lock. FYI, the reason caps lock is used is because RDP really messes with autohotkey scripts and capslock is one of the few keystrokes that get sent to the home computer rather than the guest computer.

To get this to work, download autohotkey, save this script as a .ahk file and execute it on the home computer.

If you want to retain control over your capslock key, replace "Capslock" by "^Capslock" in the second line.

0

Win Key + Alt + Tab will work.

  • This key combination has the same effect as ALT + TAB for me. It does not let me leave the RD session and switch to a program on the host. – christoph Sep 24 '16 at 9:24
0

Try connecting through mstsc (Start->Run->mstsc). I was initially connecting through RDP Client and tried the solution provided above by Josh but it did not work. When I connect using mstsc and applied the solution, it works.

  • 1
    What do you mean by the "RDP Client"? The "Remote Desktop Connection" actually is mstsc.exe. – Dawid Ferenczy Rogožan Aug 24 '16 at 11:19
0

Ctrl + Alt + Break = Break out of remote desktop full screen

If your keyboard doesn't have the Break key, you can use:

Ctrl + Alt + Pause

Once you break out of the Remote Desktop full-screen, you can use

Alt + Tab = navigate to other applications

Windows + Up = full-screen focused application

This is a big productivity boost because you never take your hand off the keyboard to you mouse. If you get really good, you'll never have to use the mouse again :)

0

Still a nuisance six years later... I wanted to be able to alt tab inside and outside the server. The best of both worlds.

(Windows 10 Home, and Windows 2012 Server)

Nothing should go wrong, but since this grabs Left Mouse Button and Enter, probably save all your work first.

I gave my local computer full access to Windows Key Commands even while RDC is maximized

RDP Options. local resources tab

And then wrote an AutoHotKey script (I am not well-versed in it) that captured WIN+TAB (#Tab), while RDC is open and then uses that and the ALT+Page Down built into Terminal Services to activate the server's ALT+Tab. Once it's open, you can navigate with arrow keys and enter/click to select.

If you can improve upon this, please do, and share.

#persistent
#Tab::WinTabbing()
return

WinTabbing() {
    WinGetTitle, Title, A                             ; Get Title
    StringRight, TitleEnd, Title, 25                  ; RDC is 25 letters long
    If (TitleEnd = "Remote Desktop Connection")       ; Check that an RDC is active. This will probably have
                                                      ; issues with the inital "connect to dialog of RDC
    {
        Send, {Alt down}{PgDn}                        ; Press and hold alt, and press pgdn
        Hotkey, Enter, Entering, On                   ; Map Enter, Click, and their alt-counterparts to Entering()
        Hotkey, !Enter, Entering, On
        Hotkey, LButton, Entering, On
        Hotkey, !LButton, Entering, On
        return
    }
}
; There is no return statement at the end of this function, because we want
; Control Tab to work when focused in any other window.

; I tried to map Tab/Alt Tab (because alt is still pressed) to Right arrow
; and Control Tab/Control Alt Tab to left arrow. I was unable to get it to work.
; I left the functions in comments if anyone want to try    
; Righting()
;   Send, Right
;   return
; }

; Lefting() {
;   Send, Right
;   return
; }

Entering() {
    Send, {Alt}{Enter}                                ; Releases Alt, and makes the selection
    Hotkey, Enter, Entering, Off                      ; See WinTabbing()
    Hotkey, !Enter, Entering, Off
    Hotkey, LButton, Entering, Off
    Hotkey, !LButton, Entering, Off
    return
}
0

I eventually chose to use the "on this computer" option Josh mentioned and use the Alt+PgUp resp. Alt+PgDown combinations in the remote. You can set this as default by editing the (hidden) Default.rdp:

mstsc /edit %USERPROFILE%\Documents\Default.rdp

I had to set it readonly to prevent it being obscurely changed when connecting to computers I had used before.

0

I am using Windows 10. None of these worked for me.. Well, I got an answer by trying out everything specified here.. To go to RDP from host machine ALT + TAB works and from RDP to host machine WINDOWS KEY + PGDN (page down) works...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.