26

Is it possible to disable auto correct (such as fixing capitalization) for a specific style template only? I'm interested in a solution for Word 2013.

This is specifically for auto correct, configured File / Options / Document proofing (?) / Auto Correct.

The purpose is to disable it for the style sheet used for code samples. Auto correct from int to Int is painful, but I don't want to lose auto correct completely.

  • I would like this for the exact same use. – John Apr 28 '15 at 17:07
2

MsWord - > In the Styles group on the Home Tab (Expand it)->Apply Style ->(Selected style is to be Normal) modify (do required modification)->Format->Language -> uncheck the spell check(if thats also not required)

for specific style you can check this link

http://blogs.msdn.com/b/acoat/archive/2009/08/09/turning-off-proofing-and-autocorrect-in-word-2007.aspx

  • 8
    This is already enabled, but turns off spell checking only (squiggly lines). However, auto correction (as configured in file / Options / Document proofing (?) / Auto Correct) is still active, e.g. changing capitalization and the beginning of a paragraph. – peterchen Feb 7 '13 at 12:20
1

Not sure if it's possible with templates, but you could use a macro for disabling the autocorrection features which you don't want on launch of the file and re-enable them on close.

Something in the direction like this:

Application.AutoCorrect.TwoInitialCapitals = False

or a little bit more general

Application.AutoCorrect.ReplaceText = False
0
  1. Go to Modify style
  2. At the bottom of the page, choose paragraph section for style editing
  3. Goto second tab Line and Page Breaks
  4. Check formatting exceptions: Suppress line numbers and Don't hyphenate

Certified and works on Mac MS-Word version 16.x

  • Does not work for me on Windows MS Word 2016. – Manuel Hoffmann Feb 15 '19 at 11:16
-1

For disabling autocorrect option MSword -> file->option ->proofing

You will options to disable it.Also from 'autocorrect option' inside proofing.

  • 2
    That’s explicitly not what @peterchen asked for. He wants to turn it off only for a particular style, not for everything in the program. – KRyan Aug 23 '13 at 22:51
-1
  1. Go to your Charms Bar (press Windows + C).
  2. Click Settings.
  3. Click Change PC Settings (located at the bottom of the Settings column).
  4. Click General.
  5. Go to the Spelling section.
  6. Turn off “Autocorrect Misspelled Words” option.

To close this app, move your cursor to the top of the page until it becomes a hand icon now click and drag off the screen.

  • This disables AutoCorrect completely, not just for selected style sheets. – peterchen Feb 29 '16 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.