I followed these instructions (https://stackoverflow.com/questions/12257110/can-you-force-visual-studio-to-always-run-as-an-administrator-in-windows-8) to force my Visual Studio 2012 to always run as administrator in Windows 8:

  1. Select "Troubleshoot program"
  2. Check "The program requires additional permissions"
  3. Click "Next"
  4. Click "Test the program..."
  5. Wait for the program to launch
  6. Click "Next"
  7. Select "Yes, save these settings for this program"
  8. Click "Close"

However, now I want to undo this and make it run as my account (i.e. without elevated permissions). How can I achieve this?

For those interested, the reason I want to go back is because some features (such as drag-and-drop files into VS, open files from Windows Explorer, etc.) no longer work.

  • Its very likely the drag and drop feature never worked for you since its not disable on my home computer and I follow the same instructions. – Ramhound Feb 7 '13 at 12:08
  • To confirm, the drag and drop features don't work between applications at different privilege levels (e.g. Windows Explorer @ normal and Visual Studio @ Administrator, in my case). – m-smith Apr 23 '18 at 11:01

Okay, I think I've worked this one out...:

  1. Right-Click on the executable (in my case: %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE\devenv.exe)
  2. Choose "Troubleshoot compatibility"
  3. Click "Troubleshoot program"
  4. Uncheck any and all checked items
  5. Click "Next"
  6. Choose "No, I have finished investigating the problem - undo any changes made and clear all settings"
  7. Click "Next"
  8. Click "Close the troubleshooter"

If necessary, go back in and set any other compatibility options again.

For some reason, it wasn't saving my removal of "The program requires additional permissions", unless I chose to completely remove all compatibility settings. Therefore step 4 is the bit I was getting wrong before.

  • 1
    I'm a big fan of windows 8 - but this is ridiculous...thanks for the workflow though, I couldn't figure this out for the life of me – Robert Petz May 13 '14 at 15:56
  • I came to this same solution on my own. Seemed to work, but definitely a perverted workflow. – Dan Jan 16 '15 at 15:10
  • Do you know what registry flag this sets? – Glade Mellor Dec 2 '15 at 17:44
  • Finally! This fixed a nuget issue for me when accessing certain mapped/network drive locations. The error I was getting was: the path for the selected source could not be resolved – goku_da_master May 19 '16 at 17:20
  • @RichardPetheram thanks, I've amended the question to include tag and heading for Windows 10. – m-smith Apr 23 '18 at 11:00

From the start screen:

  1. Right click the app tile
  2. Open file location

From the Explorer ribbon:

  1. Click Properties
  2. Navigate to the Compatibility Tab
  3. Uncheck "Run this program as an Administrator" and hit apply

Source (Refer to Using the Compatibility Tab): http://msdn.microsoft.com/en-us/library/windows/desktop/hh994464(v=vs.85).aspx

  • 1
    This only applies to the shortcut on the Windows 8 "start" screen and does not make any changes to the way the executable opens if, for example, I double-click on the exe itself (or, in my case, open the application by double-clicking an XML, C# or VB file). Sorry, I have to mark this answer down as it doesn't answer the question. – m-smith Feb 7 '13 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.