I created a new windows 7 SP1 base image. Everything is all fine and dandy with that.

So i am now installing standard applications

I would like Quicktime to manage .mov files. The only problem is WMP (Windows Media Player) won't give up the association to .mov files.

It's driving me crazy... i've been reading threads on how to fix file associations.

I would like to do it via registry, powershell or cmdline. I cannot use GPO

I've tried the following:

assoc .mov=QuickTime.mov
ftype QuickTime.mov="%ProgramFiles(x86)\QuickTime\QuickTimePlayer.exe"

Reg add HKCU\Software\Microsoft\windows\CurrentVersion\Explorere\FileExts\.mov\UserChoice" /v Progid /d QuickTime.mov /f

Reg add HKCU\Software\Microsoft\windows\CurrentVersion\Explorere\FileExts\.mov\OpenWithList" /v a /d QuickTimePlayer.exe /f

Reg add "HKCU\Software\Microsoft\windows\CurrentVersion\Explorere\FileExts\.mov\OpenWithList" /v b /d wmplayer.exe /f

Reg add HKCU\Software\Microsoft\windows\CurrentVersion\Explorere\FileExts\.mov\OpenWithList" /v MRUList /d ab /f

Reg add HKCU\Software\Microsoft\windows\CurrentVersion\Explorere\FileExts\.mov\OpenWithProgids" /v Quicktime.mov /t REG_NONE /d 0000 /f

Reg add HKCU\Software\Microsoft\windows\CurrentVersion\Explorere\FileExts\.mov\OpenWithProgids" /v WMP11.AssocFile.MOV /t REG_NONE /d 0000 /f
  • linglom.com/2008/12/06/… see part 2 too – STTR Feb 7 '13 at 19:41
  • did i miss something? both parts are about WMP being deployed via Group Policy. I'm trying to assign .mov file extensions via cmdline powershell or registry. i can see how my question is misleading... let me rephrase it. thanks! – Paul Mung Feb 7 '13 at 20:23

Firstly, the "assoc" command changes the general association of the file type in HKEY_CLASSES_ROOT. If you check the entry in regedit, I expect that you will see that you are able to successfully change it. This won't help you if there is already a user preference set in the UserChoice sub-key because it takes priority. I suspect you already know this and that's the reason you are trying to change the other registry keys directly.

The next item I noticed was an error in the key path. You're using "Explorere" instead of "Explorer". This probably means that you are getting no error message when you try to change the key. If you are creating a new unused key then it will have no effect on the behaviour of the file.

Next, you appeared to be asking about how to change the key but didn't seem to be worried about the method (as long as it is scripted) so I just tried one: powershell. A security exception is raised every time I try to write UserChoice but not for other keys. The problem appears to be the access rights for this particular registry key. When I read out the acl in powershell I could see the registry access rule for my account had "SetValue" as "Deny".

The following page gives an excellent description of how to get around this problem and remove the required permissions. Here's the resulting script that worked for me on my Win7 PC. I checked using a .mov file; the script successfully changed the program that was called when double-clicking the file.

$user=<your user account name>
$name = "Software\Microsoft\windows\CurrentVersion\Explorer\FileExts\.mov\UserChoice"
$RegKey ="HKCU:\" + $name
Get-ItemProperty -path $RegKey
get-acl -path $RegKey
$key = [Microsoft.Win32.Registry]::CurrentUser.OpenSubKey($name, [Microsoft.Win32.RegistryKeyPermissionCheck]::ReadWriteSubTree,
$acl = $key.GetAccessControl()
$rule=new-object System.Security.AccessControl.RegistryAccessRule ($user, 'SetValue', 'Deny')
get-acl -path $RegKey
Set-ItemProperty -path $RegKey -name Progid -value 'WMP11.AssocFile.MOV' -type String
Get-ItemProperty -path $RegKey

If there is any further error, then I suggest you compare the acl permissions. The script prints out the acl before and after and also the current contents of the key.

Notes 1. The displayed icon may not be updated. Double click a .mov file to test. 2. If there are problems then try to verify that you can change the value manually and that you can see the equivalent change in regedit.

Update: I was presuming that you wanted to keep the user-specific setting, but on reading your description a second time, I realised that you didn't specify this. If you want to change the association for all users then you'll have to remove the UserChoice key completely with a relatively simple command like this. Then your "assoc" command should do the trick.

| improve this answer | |
  • tiktok: thanks for your reply. I will give this a try and let you know if it work. I will mark the question as answered once i confirm. You are correct in all your assumptions.... about the typo. my apologies, i actually had it right before but i copied and pasted from a different document and that was the result :) – Paul Mung Feb 12 '13 at 17:49
  • tiktok: Thanks... i finally got back to working on this today. and i confirmed functionality of this. The funniest thing users access to Set Value wasn't Deny. They did not have any deny permissions on UserChoice - so i just made the change. Thanks!!! – Paul Mung Mar 8 '13 at 23:24
  • Just as a side note for anyone reading... VLC took over permissions of the .mov so i creates a VBScript that will set it back. – Paul Mung Mar 14 '13 at 21:25

Try Default Programs Editor. Go into file type settings, choose .mov files, then change the Open item to be Quicktime.

Then, you can save the change as a .reg file to inspect/apply/save/deploy.

| improve this answer | |
  • I'll give this a try... i prefer not to rely on third party apps... but it's always good to have multiple solutions. thanks for your insight Factor – Paul Mung Feb 12 '13 at 17:54
  • 1
    this works as well. both methods pointed me back to the solution. thanks for your help. This is an awesome program i will be using it in the future. – Paul Mung Mar 8 '13 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.