I have a CentOS6 virtual machine running on VMWare Workstation 7 and I need to boot to a LiveCD to increase my disk size. My problem is that I cant get the VM to boot to the ISO. It always boots to CentOS.

I downloaded the ISO and in the VMWare settings, I mounted the ISO to the CDROM. I start the CentOS machine, hit escape to get to the boot menu and select the CDROM as the boot device. I wait for it to finish and the normal CentOS login prompt appears.

What am I missing? Why wont VMWare Workstation boot to the CD?

3 Answers 3


Sounds like you may need to modify your boot order. I'm looking at VMWare Workstation 8, not 7, but when my VMs are shut down, one of the options that I see on the power menu is "Power ON to BIOS" and if I choose that option, I get a virtual BIOS that lets me configure the boot order. I assume that v7 has the same, or something very similar, and you just need to ensure that it's checking the CD-Drive for a bootable image before the hard drive.

  • I dont have that option, but I was able to get into the BOIS and manually change the boot order. No luck :(
    – Jeff
    Feb 8, 2013 at 3:12
  • Hmm. That worked for me. Forgive me if it's obvious, but when you say you manually changed the boot order in BIOS, you changed in in the virtual BIOS in the VM, and not the BIOS on the host machine, correct? And can you go back in and ensure that your changes were saved?
    – Xander
    Feb 8, 2013 at 14:01
  • 1
    Additionally, according to VMWare's documetation, you should have the BIOS power option in 7. "Workstation 7.x and later To enter the BIOS setup for the guest operating system, click VM > Power > Power On to BIOS." From: kb.vmware.com/selfservice/microsites/…
    – Xander
    Feb 8, 2013 at 14:04
  • Thanks for that tip. Yes, I was referring to the guest BIOS.
    – Jeff
    Feb 8, 2013 at 19:35
  • 1
    Power on to BIOS is also available via r-click context menu when the VM is selected in the Library pane. Feb 13, 2014 at 18:59

It turns out that it was a stupid mistake. The CD-ROM was not "Connected at power on."

To change this, go to VM > Settings > CD/DVD. On the right site, there should be a couple check boxes for "Connected" and "Connect at power on." Make sure they are both on.


In other versions of VM Workstation you can access the "Power On To BIOS" option in VM > Power > Power on to BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.