I recently installed Windows 8 on my computer. I have just one user, connected to a Microsoft account.

My problem is that many setup files (Chrome, Flash, Dropbox, just to mention a few), if launched with a double click, just don't start. If I right-click and choose run as administrator they run fine. Is this normal on Win 8, or there's a problem with my configuration?


I temporarily solved the problem by creating a new local account, but after some days the problem started again.

Installers that have problem include:

  • The nVidia graphics driver installer
  • Chrome setup
  • Dropbox setup (I solved this by modifying the temp directory permissions allow read/write access to Users)
  • Steam install (MSI installer) gives error 1723 "A DLL required [...] could not be run"
  • Google Play music manager (if I run it as admin, the prorgam is installed but with graphical problems)
  • Have you upgraded to Windows 8, or did you do a clean install? – harrymc Feb 20 '13 at 18:54
  • 1
    Clean, and also reinstalled again for another problem. I've sorted out the problem, which regards the permissions of the Temp folder. I'm still not sure on how they got changed. – Pincopallino Feb 20 '13 at 18:57

Check your UAC settings. Sounds like you've got it set to Always Deny or disabled entirely so that you're not being prompted to approve elevated access.

Alternatively it may be a permissions issue. Make sure that AppData\Local\Temp is set to allow Administrators full access, Users read-only access and YOURUSERNAME full access.

  • UAC settings are as default and they are ok, and I receive prompts. For example, the nVidia driver setup prompted for elevated access, but then the setup program terminates. I managed to start the setup by running the file from an administrator command prompt – Pincopallino Feb 20 '13 at 10:34
  • What happens if you run the setup in Windows 7 compatibility mode? – PhonicUK Feb 20 '13 at 10:56
  • I just modified the permissions on AppData\Local\Temp to allow complete access to Everyone and now the installers run fine. Have the default permissions on the temp folder changed since Windows 7? Do you think this would be harmful for my PC? – Pincopallino Feb 20 '13 at 11:28
  • You'd expect it to allow Administrators full access, Users read-only access and YOURUSERNAME full access. Anything other than that would be an issue. – PhonicUK Feb 20 '13 at 11:49
  • 1
    @Pincopallino - No...They have not changed the fact you had to change them indicates a serious problem with your installation. – Ramhound Feb 20 '13 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.