Whenever I run the following in a command prompt:

taskkill /f /im chrome.exe

I get an error saying "the system cannot find the file specified".

I've tried that command without the /f option, and with other processes, but get the same result. I've researched the error message but haven't found anything useful.

How can I fix this? Alternatively, is there another way to kill processes from the command prompt?

I'm running Windows 7 Home Basic 32-bit, only doesn't work on netbook.

Tasklist gives the same error, and I've read somewhere that tasklist is not avilable in the Home Basic edition, so can the same be true for taskkill as well? Although I can see that both taskkill and tasklist executables exist in the system32 folder.


Not sure about Win7 Home Basic, but if taskkill.exe and tasklist.exe don't exist in Windows\System32, just use PsKill instead (also available as part of the PsTools Suite).

  • i ll try pskill now, but those files do exist... ok pskill worked, thank you very much ! – user196791 Feb 8 '13 at 21:09
  • 1
    If they do exist, then check the PATH environment variable and confirm that Windows\System32 is the very first directory specified. – Karan Feb 8 '13 at 22:12

I am guessing that your PATH environment variable is not set correctly. Run echo %PATH% in Command Prompt, and if the output does not include C:\Windows\system32, then that is your problem.

To fix:

  • Go to Start Menu
  • Right click Computer
  • Click Properties
  • Click Advanced System Settings
  • In the Advanced tab, click Environment Variables
  • Under System Variables, find PATH
  • Click Edit
  • Put C:\Windows\system32; at the start of PATH
  • Click OK and Apply until you are out of everything
  • You may need to reboot your computer for the changes to take effect

Hope this helps!


I believe that the windows standard task manager can easily do what you ask.

  • i know, but i need to do it from cmd – user196791 Feb 8 '13 at 20:32
  • 2
    In the future please include all revelent information in your question so that you get an answer appropriate to your situation. – mdpc Feb 8 '13 at 20:34

Taskkill is not available in Windows XP/7 Home edition.

Instead you can use tskill which is available in all Windows editions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.