I recently installed windows 8 pro on my windows 7 using the option -keep settings and app but after installation I opened word , which gives me a message saying the auto-save file in /AppData/Roaming/Microsoft/office/MSO1033.acl is read only, I also tried to open other programs like skype which failed at login , visual studio 2010 ultimate which doesn't open at all, I came to a conclusion that any application has any related files in the Appdata , I have to run using "run as administrator" in order to work , this is really annoying me , so I wonder if there is a way to fix this problem?!

migrated from stackoverflow.com Feb 9 '13 at 9:39

This question came from our site for professional and enthusiast programmers.

  • Under win7 you would disable UAC, probably you can do it under Win8 – marcinj Feb 8 '13 at 20:58
  • @luskan - It's not a UAC issue, just the same as it isn't a UAC issue under Windows 7... – James Snell Feb 9 '13 at 11:41

It looks like you don't have permission to write into those folders, if you go to your AppData folder in explorer you'll probably find that you wouldn't be able to rename or delete those files. This is an NTFS permissions problem that looks like it didn't get picked up in the upgrade.

You'll need to go to the AppData folder, right-click it and go to Properties -> Security -> Advanced -> Change Permissions.

Make sure your username has 'full control' in the list of users and permissions, add/edit it if you need to. If you don't have the rights it will prompt for an admin account. Then TICK Include inheritable permissions from this objects parent and replace all child objects permissons with inheritable permissions from this object.

Once you hit ok you should be good to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy