Today I got below error in opening Stackoverflow in firefox:

Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load.

When I tried to open stackoverflow in firefox I got an error but strange thing is that its working fine in chrome even I'm posting this question from the same system on chrome browser.

I'm using windows 8 and getting error in firefox 18.0.1 and chrome of 24.0.1312

Can anyone please tell what's going wrong?


I get the same exact error in Internet Explorer 10 if I view any of the stackexchange sites with "Tracking Protection" enabled. I subscribe to several Tracking Protection Lists (Or TPLs as IE likes to call them.)

In Firefox 18.02, I have the NoScript and AdBlock addons. Again, subscribed to one or two add lists like "Easy List", etc. I get the red banned, "Super User works best with JavaScript enabled" at the top.

Below: Click 1, then 2 to disable Tracking Protection for IE 10.

enter image description here

  • Hi Mark, What's the solution? – djtechie Feb 11 '13 at 11:21
  • For IE10, turn off Tracking Protection for the site. I'll add a screenshot. For FireFox, tell noscript to allow scripting for this site. – Mark Allen Feb 11 '13 at 19:04
  • Thanks Mark, Please paste screen shot for firefox and please tell me the reason why it happens only in firefox as I don't have any unnecessary addons in firefox only web developer tool and firebug then what should be the reason for that? – djtechie Feb 12 '13 at 7:03
  • Since you don't have any addons in Firefox, I don't know why it happens there. For me it didn't happen in Firefox until I added NoScript. Screenshots won't help since you don't have the addons. – Mark Allen Feb 12 '13 at 7:47

I had this issue, with only Firefox failing and Chrome still working fine. Clearing the cache fixed it. You can do that like this:

Options -> Advanced -> Network -> Cached Web Content -> Clear Now


The problem is caused definitely by "Tracking Protection", which might be implemented in several ways, in different browsers.
In my case it was only in Chrome, where I have "Avira Safety Browser Plug-In" enter image description here

In the Avira Safety Browser Plug-In Settings I allowed the 4 trackers, and restarted Chrome browser. It works fine on all StackExchange sites, SuperUser, etc.enter image description here So the user should check the particular browser, depends on what "Tracking Protection" is activated, and how it is controlled, and allow at least Google Apis.

  • Thanks Victor for your efforts and help. I'm voting up as it also seems a solution.However accepted answer worked for me. – djtechie Apr 13 '16 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.