17

I have recently upgraded to Windows 7.

I use rdesktop from my linux desktop to remote in.

The Win7 system default mouse pointer theme is white with a black outline. However, when using rdesktop, the black outline is not displayed, rendering the pointer invisible when on a white background.

I have tried using the black pointer theme, but there one or two pointers which don't have a black counterpart (eg: the pointing finger for when you mouse over a url) - these too disappear.

This problem does not occur on WinXP.

Is there any way to get a black outline on rdesktop to Win7?

  • 1
    Have you tried downloading and compiling the latest version of rdesktop? I had the same problem, and this worked for me. – Derek Pressnall Feb 10 '13 at 23:21
  • Thanks Derek - I am running an older version - will upgrade – Steve Lorimer Feb 11 '13 at 4:17
  • Hmmm - upgraded - still not working! :( – Steve Lorimer Feb 11 '13 at 5:32
18

Just go to control panel, on the remote Windows 7 desktop, and disable Mouse pointer shadow, in the mouse configuration section.

| improve this answer | |
  • 1
    Finally! This also applies to later versions (Server 2012 in my case). – musiKk Oct 6 '14 at 14:36
  • Open control panel, search for mouse, choose mouse properties, tab pointers, disable 'enable shadow pointers', click Apply and the pointer should immediately change. – Harald Aug 25 '16 at 10:17
  • Worked for me as well on Windows 10 with rdesktop – The Vivandiere Jan 8 '18 at 18:40
5

I have just solved this over at Unix & Linux StackExchange. In short, you can tell Xorg to override the cursor that rdesktop is trying to set, so that you get a different cursor instead:

$ mkdir -p ~/.icons/default/cursors
$ ln -s /usr/share/icons/Vanilla-DMZ/cursors/left_ptr ~/.icons/default/cursors/24020000002800000528000084810000

In this case the default Windows 7 cursor (2402...) is being replaced by the default arrow (left_ptr) from the Vanilla-DMZ cursor theme. Adjust as appropriate. The change should be visible as soon as you close and reopen rdesktop.

| improve this answer | |
  • In my case, it was a right cursor on visual studio which was screwed up. I'm on arch, so a little different set of cursors. Anyway, here's the command line for those who are trying to fight that plague: ln -s /usr/share/icons/mate/cursors/right_ptr ~/.icons/default/cursors/e0059efb1a34ffc5bb00005f87803e11 – galets Nov 21 '14 at 15:40
  • I'm on Arch too. The instructions here are distribution agnostic, the key is to make sure you pick the same cursor theme if you want the cursors to match (although there's nothing stopping you from mixing and matching between themes.) – Malvineous Nov 21 '14 at 21:20
  • it would be good if there was an easy way to detect and replace the whole set of cusrors – galets Nov 21 '14 at 22:24
  • For ubuntu trusty (14.04), I adjusted the answer as follows: ` mkdir -p ~/.icons/default/cursors ; ln -nfs /usr/share/icons/DMZ-White/cursors/left_ptr ~/.icons/default/cursors/24020000002800000528000084810000 ` – iheggie Aug 24 '15 at 2:17
  • Unfortunately the cursor fix didn't work for all servers - I ended up installing ftp.us.debian.org/debian/pool/main/r/rdesktop/… from debian (Thanks labs.sasslantis.ee/2014/09/… ) – iheggie Aug 24 '15 at 2:49
0

Following the solution already posted to override the unknown cursors I wrote a script that fixes all Aero cursors. The challenge was to identify all cursor hashes, especially the animated ones (17 hashes per cursor). Its on https://github.com/DavidLP/rdesktop_cursor_fix. You can also just copy the hashes from the script and link it to the Linux cursors you like. I would have commented to the answer already given but the reputation systems prevents this...

| improve this answer | |
0

My situation: Logging onto a Windows 10 computer host with a Ubuntu 14.04 client using rdesktop.

My problem: Both the remote Windows desktop background and the remote Windows mouse were black rendering the mouse pointer invisible i.e. black on black.

My solution: Change the black Windows remote mouse pointer to white To change a black mouse pointer to white:

  1. Go to the lower-left Windows screen to the start menu (lower left corner)
  2. in the Type here to search box type: control panel
  3. and from the resulting control panel menu select: Hardware and Sound
  4. from the resulting menu under Devices and Printers select: Mouse
  5. You should get a pop-up window labeled Mouse Properties
  6. In Mouse Properties click: Pointers on the tab (upper part of the window)
  7. With the Pointers tab selected, at the bottom of this window unselect (i.e. uncheck) the box labeled: Enable pointer shadow.

The unselecting of the Enable pointer shadow mouse control should then make your remote mouse pointer turn white so you get a white mouse pointer on the black remote background.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.