My Cicso AnyConnect VPN client on Windows 7 suddenly started giving the error:

Failed to initialize connection subsystem.

Rebooting didn't help. How can I resolve this?

  • Latest Poodle SSL3 fix KB3023607 causes this error sporadically on Windows 7 and on every Windows 8.1 system I manage. Haven't hit the Work Offline issue, but one of my users will find it as well. – Fiasco Labs Feb 19 '15 at 23:04

The most recent Windows patch-Tuesday update - KB3023607 - causes the same problem with Cisco AnyConnect VPN. Your options for correcting this include:

  1. Follow the instructions listed in Patch Tuesday: KB3023607 Breaks Cisco AnyConnect, Here's a Fix:
  1. On the Windows Taskbar, right-click on the Cisco AnyConnect icon and choose Quit.

    enter image description here

  2. Open File Explorer and navigate to: C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\.

  3. Find vpnui.exe, right-click on it, and then choose the Troubleshoot Compatibility option.

    enter image description here

  4. Choose Try Recommended Settings.

    enter image description here

  5. Click Test Program (notice that Windows chooses Windows 7 compatibility mode in case you have to set it manually). Choosing to "Test the Program" will launch the Cisco AnyConnect client, giving you the chance test logging in. It should work.

    enter image description here

  6. Once it's proven that Cisco AnyConnect works, choose to save the settings. If it doesn't work, the troubleshooter gives you the options of trying again with different settings. The Windows 7 compatibility worked for me and I run Windows 8.1.

    enter image description here

  7. Program Compatibility Troubleshooter will give you a final report. Close the troubleshooter and you should be good to go.

    enter image description here

  1. Apply Windows' "Fix it" solution:

The Fix it solution that's described in this section is not intended as a replacement for any security update. We recommend that you always install the latest security updates. However, we offer this Fix it solution as a workaround for some scenarios.

To install or remove this Fix it solution, click the Fix it button or link under the Enable this fix it heading or the Disable this fix it heading. Click Run in the File Download dialog box, and then follow the steps in the Fix it Wizard.

  • Often both vpnui.exe and vpnagent.exe need to be set to at least Windows 7 compatibility on Windows 8.1 when this happens, just did the fix this morning to resurrect Cisco AnyConnect Secure Mobility Client. End result of the last Poodle SSL3 fix in KB3023607 – Fiasco Labs Feb 19 '15 at 22:55

This problem can be caused if Internet Explorer is set to Work Offline mode.

  • Open IE
  • Press ALT and click the File menu
  • Click the Work Offline menu item if it is checked
  • I was just going to post this exact same question and answer after I figured it out myself this morning. Oddly this question doesn't come up very high in any search results that I was able to get. – Nathan Stohlmann Apr 4 '13 at 13:30
  • For me it's now the first hit at DuckDuckGo, and on first page for Google, which is a lot better than the pages of irrelevant Cisco forums I had to wade through to find that solution. Kudos if you figured it out yourself! – Nathan Kidd Apr 4 '13 at 13:57

For me it turned out the service was set to start manually and was not running. Once I started the service everything worked as before.

  • Can you add steps as to how you figured out the issue, and where you went to fix it? It would help make this answer much more valuable to future visitors. – Canadian Luke Jul 31 '14 at 21:31
  1. If you have Hyper-V running, you may need to stop Hyper-V services to resolve this error.
  2. If you are sharing a network connection, you my need to stop sharing to resolve this.

Found it by experimentation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.