I am running a Dell laptop computer with a Windows 7 Professional operating system. I have Google Chrome and Internet Explorer installed. When I open Internet Explorer the home page I get is a website that says 'AVG Secure Search'. I want to delete this. How can I do so?

I had this problem once before, maybe six months ago, and was able to solve it myself after several hours of effort. This time I cannot find a solution. If I type 'remove AVG Secure Search' into Google I find a lot of websites describing this problem, but none offer a clear and effective solution. Many of those websites are by AVG themselves, but their proposed solutions are not helpful to me.

For example, http://www.avg.com/ww-en/secure-search-uninstall says:

Step 1. Open Internet Explorer

Step 2. Click 'Tools' on the top menu, and then click on 'Manage Add-ons'.

Step 3. In the opened window, click on 'AVG Security Toolbar', and then click on 'Disable' at the bottom right corner.

However, on my computer AVG does not appear in the opened window. The default open window is for 'Toolbars and Extensions', which has a small red circle with a red diagonal line in it, suggesting to me that something is disabled.

If I click on 'Search Providers' instead of 'Toolbars and Extensions', then 'AVG Secure Search' is listed. If I click on 'AVG Secure Search' then a 'Remove' button appears in the lower right corner of the window, but this 'Remove' button is grayed out and I cannot click on it.

I have explored other websites purporting to provide assistance in removing AVG Secure Search, but these other websites often seem to recommend downloading and installing various applications with which I am not familiar.

Nor does 'AVG' appear anywhere in the listing under 'Programs and Featured' under the 'Control Panel'.

I have also checked other posts here on SuperUser that mention AVG, but have not found a post that provides clear instructions on how to remove AVG Secure Search.

Thank you for any advice. If I locate a way to remove this search engine myself, I will post the solution here.

(I am using the AVG-antivirus tag, although as far as I know I do not have AVG antivirus software on my computer. At least, I never knowingly installed it to the best of my recollection.)

  • What version of IE are you using? Right-click "remove" in "search providers" doesn't help? – Mariyan Feb 11 '13 at 20:38
  • It is Internet Explorer 9. I do not know whether it is 32-bit or 64-bit. – Mark Miller Feb 11 '13 at 21:03

Here is how I solved the problem:

  1. After clicking on 'AVG Secure Search' I clicked on the 'Move down' phrase in the lower right corner of the window until 'AVG Secure Search' was listed last (had the lowest priority). I then clicked on the search engine I wanted and clicked on 'Move up' until that search engine was listed first (had the highest priority).

  2. Then I clicked on 'Set as default' for the search engine I wanted.

  3. Then I replaced 'AVG Secure Search' as my homepage with the homepage I wanted by following these instructions:


  1. Somewhere along the line I rebooted my computer.

This solution does not seem to uninstall AVG Secure Search, but it does restore the internet search engine I want.

If anyone knows how to remove 'AVG Secure Search' completely please post those instructions here. It is a little unnerving that in 2013 an application that I do not want cannot be removed from my computer.

  • It's a while since I used AVG but the solution used to be to run the AVG installer again and deselect the Secure Search option. – David Marshall Feb 11 '13 at 21:41
  • You can uninstall AVG Secure Search in the Add/Remove Programs – Ramhound Feb 12 '13 at 12:50

To the point of David Marshall's comment, it would be easier to install the AVG software and then go to Programs and Features under your control panel and then uninstall both AVG and AVG Security Toolbar. AVG1

You can then confirm that AVG secure search is not present on internet Explorer by going into Tools, Manage Add ons and click on the Search Provider field on the left. It should not be there, but if it is, you can now disable it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.