How? Mount, Find & Recover DATA in HDD outside of Synology Box

I had originally posted this question here on Synology Forums and no real solution was suggested except a Linux / RAID based solution that worked for someone, but not for me.

I believe a LINUX & Drive/ Volume Expert could help with this as someone did use a similar solution to recover their RAIDed disk, but I was not using RAID, maybe JBOD/ SHR so I think there should be a way?

Many times I've run into issues of Synology or Hard Drive corruption/ error in sectors etc. where I have had to pretty much remove the Drive which Synology refuses to read or work with.

In such scenarios I am hoping I could use a bunch of Hard Drive recovery tools that I have after attaching the Disk to a PC/Box or Laptop via USB enclosure.

The question is, assuming I am able to detect the Hard Drive and assuming that hardware is still kind of functional, what way can I LOAD/ MOUNT the Drive (under Windows or Linux OS etc) on a PC/Laptop? (What tools/ software should I used to do that?)

I've used several Partition Management tools and I can see 4 partitions inside the Disk as created by Synology.

But, I cant seem to figure out a way to LOAD/ MOUNT the Data Volume where Synology stores my data.

Once that volume/partition is loaded (assuming there is some software/tool that can do that), how do I FIND where my DATA files and folders are stored, so that I can copy them off the Disk.

If it was a DIY Server using an OS & Partition type I had insights on it would be easy to figure out where the DATA is and attempt to recover it.

How can I do that for drives that get "messed up" inside the Synology Box?

One solutions path explored that did not work:

  • No answer for you, I've got the exact same problem. I've tried various ext4 reading windows programs, all of which can see the drive & partitions, but none of which have been able to recover data (geeksnerds, stellar phoenix, linux reader, explore2fs, ext2explore, none of which allowed me to copy, recover or even see data files).
    • Surprisingly, the drives do not auto mount in Ubuntu 12.04 either. Good luck.

Another Solution that worked well on RAIDed drive but I had no luck on my Disk (JBOD or SHR):

  1. Installed Ubuntu 11.10 (also tried with latest version 12.xx)into some spare SATA-drive. No updates needed to be installed. PC must have Internet connection.
  2. Attached drive from DS411 which was configured as RAID-1 mirror into Ubuntu PC and booted up.
  3. At "Dash Home" search 'disk utility' ans start it to see that attached drive exist and is visible in Linux.
  4. Install 'Logical Volume Management' software from "Ubuntu Software Center"
  5. Install 'mdadm'. At "Dash Home" search 'terminal' and start it. In terminal type: sudo apt-get install mdadm
  6. mdadm installation on first pop-up press 'tab' to get cursor on 'OK' and hit enter, for email configuration choose 'no configuration'
  7. After installation is complete type: sudo mdadm --assemble --scan After this command your attached Raid-1 mirror half should be visible on 'disk utility'-software.
  8. On disk utility, find selection on attached drive 'start volume group' after all volumes and array should be running, if not try to start volumes separately.
  9. Select volume where data is stored (biggest one) and below that click on 'mount'
  10. Open 'home folder' attached Raid-1 mirror half should be visible and data can be accessed and copied to other locations.

I've not had any luck using this method, but I can see the Disk attached and Ubuntu also gives me the option to format the drive. But, so far I am trying to see some way to recover the drive data.

  • I've not heard of Synology before, but what happens if you type "pvscan" ? (IE does it find a physical volume on the Synology disk ?) If it does Synology might be using LVM, to manage disks - and we can use LVM to access it then !
    – davidgo
    Commented Feb 13, 2013 at 2:38
  • Also, What does fdisk -l /dev/DEVICENAME show you (ie what is the partition structure of the disk)
    – davidgo
    Commented Feb 13, 2013 at 2:39
  • Synology is one of the leading NAS companies out there especially in the Home and Small office/ Small Medium Business space. I'll try what you suggested and see what it says.
    – Alex S
    Commented Feb 13, 2013 at 17:16

4 Answers 4


This is how I resolved the same problem with an SHR-Raid on a Synology Diskstation. First, you have to work within the terminal. Second, you will need the mdadm package.

sudo apt-get install mdadm

then you have to check how the drive is registered in Ubuntu (/dev/sdc or something like that). The next command tells Linux that you want to run this drive as a volume

mdadm -A --verbose --run /dev/md3 /dev/sdc5

with that command, you force Linux to use this as volumegroup

mdadm -Sf /dev/md3


gives back following information

File descriptor 4 (/dev/urandom) leaked on pvscan invocation. Parent PID 2451: bash
  PV /dev/md3   VG vg1   lvm2 [1,81 TiB / 0    free]
  Total: 1 [1,81 TiB] / in use: 1 [1,81 TiB] / in no VG: 0 [0   ]

with the next command, you make the volumegroup to a disk

vgchange -ay /dev/vg1
lvdisplay vg1

If you executed the steps correctly, you can find your drive in personal Folders under Ubuntu and you can mount the drive then. If you want, you can mount with terminal too:

mkdir /media/syno-vg1
mount /dev/vg1/lv -o ro /media/syno-vg1

Hope it works.

  • Which commandline are we using here? This steps are to be done on the commandline by SSHing into the Synology Box or on a PC / Laptop outside with the drives connected?
    – Alex S
    Commented Jun 5, 2013 at 11:00
  • Thanks a lot, this helped me get access to my data after a failed migration from ds209J to ds214! Commented Dec 19, 2013 at 23:05
  • Which commandline are we using here? This steps are to be done on the commandline by SSHing into the Synology Box or on a PC / Laptop outside with the drives connected?
    – Alex S
    Commented Dec 28, 2013 at 4:12
  • I tried this and Jos's suggestion below to use madam --assemble --scan - which eventually worked for me, but because it thought the volume was in use, I encountered this problem. I had to create a new md resource - it mounted as /dev/md/5 and I accidentally duplicated it as /dev/md/55 when changing the UUID, and it fixed it. My final command was sudo mdadm --assemble /dev/md/55 --update=uuid —uuid=<newUuid> /dev/sdc5 Commented Feb 28, 2019 at 21:31

A bit late but of course we are using the Linux command line of the PC.

The drive is not in the DiskStation (that broke down) and this thread is about connecting the disk drive with all your movies to your PC and trying to rescue them to another hard disk.

The first solution (install LVM in the GUI and mdadm with apt-get) worked for me. After mdadm --assemble --scan I could access the partition in Disk Manager and mount it.

BTW. If you bought another DiskStation you can save all this trouble. There is a non-destructive way to install DSM on your hard disk, so afterwards you can use the new NAS as if it was the old one. Look on the Synology site.


Faced the exact same situation! Tried unsuccessfully the solution involving mdadm... that was to obscure to me. Tried UFS Professional Recovery with all disks removed from synology and plugged in a spare computer I had left. I can now browse my volume and restore files on demand. Here are a few screenshots I found on the net http://downloads.informer.com/ufs-explorer-professional-recovery/screenshot/994150/


For ubuntu 18. I am not an expert of lvm or mdasm but here what i have done to solve. A single hard drive SHR attached trough USB-SATA adapter. The system try to set automatically the RAID volume, but something goes wrong:

If I try to assemble:

mdadm -Asf && vgchange -ay

mdadm: Found some drive for an array that is already active: /dev/md/DiskStation:2
mdadm: giving up.
mdadm: No arrays found in config file or automatically

or mount:

mount /dev/mapper/vg1000-lv /mnt/
mount: /mnt: can't read superblock on /dev/mapper/vg1000-lv.

I have cheched and the system already mapped a /dev/mdXXX to the SHR drive. So:

dmsetup remove /dev/mapper/vg1000-lv

mdadm --stop /dev/mdXXX

And after it's possible to retry to assemble with mdadm:

mdadm -Asf && vgchange -ay

The mount reference is under /media/xxxxx/volumeToMount

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .