189

Since a few months ago, Notepad++ automatically makes clickable links whenever I type a URL. This behaviour makes it much more difficult to edit HTML documents because instead of clicking in the middle of a text URL to change it, it now opens the link in the web browser instead.

How can I permanently disable this feature?

2
  • 2
    Amazing how the NPP team persists in enalbing this idiotic option by default. Not a single developer has ever needed to click a link in NPP.
    – andreszs
    Jul 6, 2021 at 14:24
  • Agreed! The same goes for the Workspace feature (disable by unchecking under Default Directory in Settings > Preferences). At first you couldn't disable it at all, so I didn't upgrade for a couple years. Now you can disable so I can use the latest version, which finally has a dark theme.
    – superuser
    Jun 2 at 2:32

2 Answers 2

241

This has moved to the Settings > Preferences > Cloud & Link

enter image description here


For users of the older versions:

You have to uncheck this option:

Settings » Preferences » MISC » Clickable Link Settings

Clickable Link Settings

Once you've changed the setting, you will need to reopen the file in Notepad++ (or restart the application) for it to take effect.

3
  • @ReverseEMF I actually used the links frequently while writing HTML files for my website. Making sure they're going where I think they're going and also I'd sometimes want to read stuff from the site I was referencing while writing content for the page.
    – Julix
    Oct 7, 2016 at 21:01
  • @nixda, I often find myself toggling this, (and I keep forgetting where in the unintuitive menu it is), any easy way to do this, like assign a key ?
    – killjoy
    Sep 5, 2018 at 16:05
  • 10
    Note: this has moved to the Cloud & Link page
    – MickyD
    May 5, 2021 at 6:09
6

As a Windows 10 user, I found that I needed to run Notepad++ as an administrator in order for this setting to "take". This is probably true for other versions of Windows.

I discovered this after several attempts to uncheck the Clickable Link Settings checkbox. After restarting Notepad++ several times and finding the checkbox still checked, I found this solution from searching Google.

2
  • Can confirm that this worked in my case. Had to run Notepad++ in admin mode in order to be able to "deactivate" links.
    – Hauns TM
    Mar 26, 2018 at 11:38
  • Did you install Notepad++ with the option Do not use %APPDATA%? This would be the only explanation for me.
    – escalator
    May 11, 2020 at 14:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.