I've been having problems installing Homebrew since changing my home username on my Mac OSX 10.6.8 computer. After removing all files from the previous Homebrew installation since that didn't work, I installed it again. When I run brew doctor, it says:

Warning: Suspicious git origin remote found.

With a non-standard origin, Homebrew won't pull updates from
the main repository. The current git origin is:

Unless you have compelling reasons, consider setting the
origin remote to point at the main repository, located at:

It wouldn't let me install git (I did it with the package installer) and now when I try to run brew install libksba, it says:

Error: Permission denied - /Library/Caches/Homebrew/Formula/libksba.brewing

I've tried doing chown and looking up anything that would help but I'm not finding anything. Any chance anyone knows how to fix this?

  • What exactly did you change ("home username")? And how did you install Homebrew? It looks like Homebrew's git origin is blank, which shouldn't happen, so this might be something to ask the Homebrew developers. Feb 13 '13 at 0:14
  • I changed my account name so what you see after, -Macbook-Pro: ~home username in the Terminal. I had to delete a past install and then I used the curl script on the homepage for it.
    – Anoel
    Mar 2 '13 at 23:44

Running this command fixed it for me just now (I was having the same problem)

sudo chown -R ${USER} /Library/Caches/Homebrew/

What does "ls -al /Library/Caches/Homebrew/Formula/libksba.brewing" look like?

The file may be owned by another user on you computer, probably from brew update etc. Try giving write permissions to group.

sudo chmod g+w /Library/Caches/Homebrew/Formula/libksba.brewing

I also changed my account name, although it's not clear the brew issue is related. In any case, run 'brew update' from the command line, to pull down the latest updates (bug fixes), then 'brew doctor' again to confirm you're all good.

  • I did that, it downloaded the last updates, brew doctor says I'm good but it still says the same thing.
    – Anoel
    Mar 2 '13 at 23:44

I was running into the same problem and changing the permissions on the Homebrew folder fixed my problem. Simply run the following command:

sudo chmod -R g+w /Library/Caches/Homebrew

Thanks to @cgl for suggesting changing the folder permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.