27

I have several (4-6) different Google accounts, I use the Gmail addresses for different reasons and I forward the emails from all of them to a single Gmail account.

Occasionally, important messages in these various Gmail accounts will get mistakenly sent to spam (false positives). These messages do not get sent to my catch-all Gmail account. These false-positive messages are never critical (if they were, I'd choose to have them sent to my "main" account), but this has happened frequently enough that I wish there was a way to disable or bypass Gmail's spam filter so that every message comes through and the spam filtering only happens in one place.

If the spam filtering only happens in one place, I only have to check one place for false positives. Gmail's filters are excellent, but they're not perfect.

31

The solution to this is not to use Gmail's "forward a copy of incoming mail" feature, but instead to create a filter. Filters are applied to incoming mail before spam detection takes place, giving the option to "never send to spam" in the filter rules. The forwarding filter should use Gmail's "deliveredto:" operator, which handles messages that use plus addressing and messages addressed to mailing lists.

In a nutshell:

  • disable forwarding if you're already using that to redirect messages to your destination address
  • create a filter with the following criterion and actions
    • Has the words deliveredto:your_incoming_address@gmail.com
    • Forward it to your_destination_address@example.com
    • Never send it to spam

I have verified that this approach works.

  • 8
    What also works (been using it for years), is to create a filter for "label:spam" and set the action to "never send to spam". Then, all incoming spam messages will also be forwarded. – jmiserez Jul 3 '14 at 11:53
  • how to create a filter for "label:spam"? – Ankit Vora Aug 11 '15 at 15:17
  • 1
    Jmiserez: This sounds like a separate answer, and maybe a cleaner one. Can you separate it out as an answer? – CPBL Apr 27 '16 at 15:35
  • 2
    @jmiserez does this still work? When adding a filter like this, I see the following message: Filter searches containing "label:", "in:", "is:", date range (e.g. "before:" or "after:") or stars criteria (e.g. "has:yellow-star") are not recommended as they will never match incoming mail. Do you still wish to continue to the next step? – bers Feb 27 '17 at 13:57
  • @bers, I also get the same message. – Pacerier Dec 11 '17 at 18:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.