I have a Vista machine that used to be hooked up to a widescreen monitor, I moved and no longer have the monitor and planned to just hook it up to my widescreen TV's VGA input jack. I can see the initial DOS-type boot screen, and see the "Windows is about to boot" screen, but everything goes black and my TV displays an "unsupported video signal" message right before it would normally show me the Vista circle logo and have me select a user to log in with.

If I boot to safe mode I can get into Vista, and can set the resolution from the safe mode 600 X 800 to a higher res and see everything fine, but no matter what settings I change in safe mode I cannot get the regular boot to honor them.

I don't have the old monitor, or another monitor, to hook up to and change the resolution that way, but if I absolutely have to I can probably manage to get to another monitor. It seems that is the obvious fix.

But does anyone know how to get a safe mode change to stick? Or know the keystrokes I could enter blind to get from Vista user log in to resolution change screen? Or any other back door way to change this setting?

  • Good question. I've always wondered about this too. – ephilip Oct 14 '09 at 0:42

Instead of safe mode boot to "Low Resolution" mode. It should be a few menu options below Safe Mode in that list.

Alternatively you can open msconfig from a command line. Navigate to the Boot tab, and put a check in the Base Video box from safe mode and reboot.

Edit: To answer your second question about detection. A monitor identifies itself to a computer, along with its specifications and native resolution over something called an EDID. The EDID resides on a ROM chip in the monitor and is a standard.

However OS vendors (such as Microsoft), video card manufacturers, and monitor manufacturers have typically done a mess of a job implementing it. This leads to shoddy support for advertisement of native res, etc, and when this happens, it causes problems like the one you are having.

| improve this answer | |
  • I didn't have a low resolution mode to select, only safe mode options. But, setting Base Video in MSConfig allowed me to fully boot into a low res Vista where I could then set my resolution correctly. Thanks. – kscott Oct 14 '09 at 2:53
  • I've seen the low res mode on some machines but not others. Not sure why, but I'm glad the other solution worked. – MDMarra Oct 14 '09 at 4:42
  • Though I have to say that I rarely had problems with this. I regularly change monitors on my laptop and so far it always set itself to the correct resolution. I wouldn't really expect a TV to honor the same standards as a normal computer monitor, though. – Joey Oct 14 '09 at 5:17
  • 1
    On windows 7 this option reads "Enable low-resolution video (640x480)" – Tim Keating Dec 9 '12 at 17:51

Your OS is trying to force the TV to use a refresh rate/resolution it can't support. You have to check your TV manual. It will list the supported combination. Contrary to a monitor, depending on your TV set, you may not have many choices here.

The refresh rate will be almost certainly 60 Hz. The resolution is entirely dependent on the TV screen size. Meanwhile if your video card has settings for TV display you should use those instead of setting anything from within Windows normal resolution dialog box.

If you provide your TV make and model, we can probably help you figure out the exact settings.

| improve this answer | |
  • Indeed I did need to get the correct refresh rate and resolution settings for the TV to finally display, but the issue at hand was getting Vista to let me see the settings to change at all. Thanks for the answer. – kscott Oct 14 '09 at 3:01

You can change the settings by blind typing if your video driver is behaving sanely.

I don't have a Vista box here to test on, but with XP you could type:

Windows key, c, d, d, enter, ctrl-tab, ctrl-tab, ctrl-tab, ctrl-tab, tab, shift-tab, down, down, enter.

This would reduce the screen resolution two steps. Use more "down" steps at the end to reduce it all the way to the minimum. Again, this is for XP, test on Vista (in Safe Mode) before trying this.

You could also boot into Safe Mode and change the video driver to "VGA" instead of whatever accelerated driver you're using. After you reboot into normal mode, reinstall the real driver and set whatever resolution you like.

| improve this answer | |
  • I was half kidding about a blind keystroke list, but think its hilarious you put them up. For the record, this set of strokes does not work in Vista. – kscott Oct 14 '09 at 2:57
  • You can still boot to Safe Mode and change to the VGA driver. – CarlF Oct 14 '09 at 3:16
  • @CarlF this won't work, as any changes you make to the settings while you are in safe mode only apply to the default driver; the refresh rate issue will pop back up once you boot back into normal mode. – Tim Keating Dec 9 '12 at 17:54

Since the display settings won't stick in safe mode, download NirCmd in safe mode and add a batch startup script to change the resolution:

nircmd.exe setdisplay 1680 1050 32

where 1680 is the width, 1050 is the height, and 32 is the color depth in bits.

| improve this answer | |
  • how much did NirSoft pay you to suggest this? j/k Quite a round about solution, thanks for the answer. – kscott Oct 14 '09 at 2:58


Above link has a much better solution - no external software required.

| improve this answer | |
  • 2
    Links go stale - maybe you'd like to edit that answer to have more details so even if the site its on had issues, people could refer to a standalone answer. Better yet, try it out, add screenshots, and post a nice, high quality answer people will love – Journeyman Geek Jun 11 '12 at 10:59

In Windows Vista Home Basic 32bit, the easiest solution is just to go to Control Panel, and in the menu that the option to change the resolution is for you. Then, you need to go to More display modes of something simiral, search the tabs and find the option:Display all modes. When you press that button, a message will pop up saying that it will now show all modes and those that the monitor doesn't show properly. Ignore that and press OK. Then, when you try to change the resolution, it will let you choose more than 2. In my case it showed me 4 modes in 32bit and the maximum was 1600x1200. Hope it works!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.