Whenever I have a decimal point in my data, the point on the graph drops down to 0 in the Y-axis.

What could be causing this? It is unusual behaviour, right?

enter image description here

  • Hi Odyssey, Welcome to Super User!, did you know you can answer your own question? It's a perfectly OK thing to do, especially if you come up with the solution yourself! I'll let you edit your solution out of your question, and post it as an answer :). Don't forget you can mark your own answer as accepted as well, so that other people visiting the site know this is what worked for you.
    – Robotnik
    Feb 13, 2013 at 23:53
  • 2
    New users cannot answer their own question for a while (8 hours, if I recall correctly). Once that time has passed, you should follow @Robotnik's advice and post your solution as an answer, then mark it as accepted.
    – Indrek
    Feb 14, 2013 at 0:18
  • @Indrek 8 hours is correct! I also couldn't post the image above inline, only a link. nixda kindly added it for me.
    – Odyssey
    Feb 14, 2013 at 0:20
  • @Indrek - I did not know that, thanks! (the more you know)
    – Robotnik
    Feb 14, 2013 at 0:53

4 Answers 4


This happens when the numbers use a different decimal symbol than the one specified in Windows regional settings, which causes those numbers to be interpreted as text.

In my case, the system language had recently been set to French, which uses comma (,) as the decimal symbol, while the numbers in Excel used the period (.). Changing the numbers in Excel and replacing periods with commas fixed the problem.

  • I rewrote your answer a bit, to explain the source of the problem and hopefully make it a bit more universal. If you think I changed too much, feel free to revert back to your original version. Also, don't forget to mark this answer as accepted (by clicking the green checkmark outline next to it), once the system allows you to do that.
    – Indrek
    Feb 15, 2013 at 17:29

Check (and correct) the setting for a decimal symbol in windows: Control panel > Region and Language > Formats > Addional Settings > Decimal symbol


This may not have been the issue for your case, but it was for mine so I thought it was worth sharing - my data was stored as text, despite being formatted as a number with the correct number decimal places.


Use the slash sign "/" instead of point "." or comma ",". It solved my similar problem once. Also try to change the format of numbers from "General" to "Number" on the excel toolbar > Home > Number.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.