I have a computer with Win XP SP3 and I was going to install a WAMP system on it. I already had a pwerfectly working WAMP (Uniform Server, it is a portable wamp that works on usb stick) on another computer (Win7) so I simply copied the whole folder to the same position (c:\uniserver) but starting the server on winxp failed with the error "php5apache2_4.dll not found".

So I went to download the single packages (apache 2.4, php 5.4.11), using this website as reference.

Extracted Apache 2.4 on c:\apache24, started and worked like a charm ("it works" page loaded fine)

Downloaded php 5.4.11 thread safe (VC9, since VC6 does not exist for 5.4) and I got the same "php5apache2_4.dll not found" error.

Deleted php 5.4.11, cleaned everything, installed php 5.4.9, downloaded the php5apache2_4.dll for php 5.4.9 from apachelounge, got the same error :(

How the hell I'm supposed to have a wamp working with latest version of everything? The php5apache2_4.dll file is there, and the path is right, but still apache gives me the error and does not start (but if I delete everything about php it start to work again), and even the uniform server wamp does not work. What I'm supposed to do now?


You shouldn't ever copy an install onto another OS/Computer. I suggest you do a clean installation and just copy your www folder from the previous system.

  • Uniform server is a portable wamp, it is supposed to work in a usbstick. And as I have explained, I have also done a clean installation with the separate packages. – Terix Feb 14 '13 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.