I'm trying to use a Gigaware USB to serial adapter on my new computer. It worked fine with Windows Vista and XP, but not on Windows 8. It's not working and I get this message under device properties in the device manager.

This device cannot start. (Code 10)

A device which does not exist was specified.

I tried downloading a different driver that I found in this post This device cannot start. (Code 10) - Gigaware USB - Serial Adapter regarding this same problem on here, not sure how I manually add it or if it needs to be downloaded in a specific location to even work. Any help would be appreciated, thanks!


If this is your adapter - then it is based on Prolific PL2303 chipset and your best bet would be to use the drivers from the chipset manufacturer. But if your adapter contains an old revision of the chip - it is just not compatible with Windows 8:

Windows 8 is NOT supported in PL-2303HXA and PL-2303X EOL chip versions.

  • 1
    I just want to point out that the direct link points to version 1.7 while the website currently offers version 1.9. 1.9 also did not work in my case, but the instructions I posted here seem to work. My device is a 067b:2303 Prolific Technology, Inc. PL2303 Serial Port (info from lsusb). – LiveWireBT Feb 11 '14 at 16:09

I found a solution that at least removes the error code 10 message.

Straight forward instructions:

  • Download and unpack Profilic_Win8_x64_x86.zip (Google Drive or Sendspace).
  • Install the driver via .ini file.
  • Go to the device manager Win+Pause or Win+X (in Windows 8) and select your USB-to-Serial device.
    • Select "Update Driver Software..." from the context menu.
    • Select "Browse my computer for driver software" and "Let me pick from a list of device drivers on my computer" in the dialogue.
    • Select the Prolific driver version 3.3.2 from 2008.

In my case the error message is gone, but I didn't have time to actually test the device functionality. Detailed instructions with pictures and links to sources can be found via the first link.

  • I've tried both 2015 and 2008 and still get code 10. – Rick Jun 26 '15 at 17:16
  • 1
    I have to adapters here one with a definitely fake chip and one that was a bit pricier (I needed that for a firmware upgrade), both currently work (i.e. the driver installs successfully) on my Windows 8.1 machine with the driver in my post. – LiveWireBT Jun 27 '15 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.