I have my VMware Player (v 5.0.0 build-812388) all up and running Ubuntu (12.10) from my Windows (Win 7) machine.

When I launch sudo vmware-config-tools.pl, it tries to search for kernel

Searching for a valid kernel header path...
The path "" is not a valid path to the 3.5.0-17-generic kernel headers.
Would you like to change it? [yes]

Enter the path to the kernel header files for the 3.5.0-17-generic kernel?

I entered /usr/src/linux-headers-3.5.0-17-generic.

The path "/usr/src/linux-headers-3.5.0-17-generic" is not a valid path to the 
3.5.0-17-generic kernel headers.

Due to this it doesn't compile modules. So unable to mount HGFS (shared folder) filesystems.

Any ideas how I can fix this?

  1. Make sure you have rebooted Ubuntu since applying any software updates. Software updates may change the kernel version.
  2. Make sure you install build-essential package.
  3. Try sudo apt-get install linux-headers-$(uname -r)
  • 1
    Hi - I have installed build-essentials and also have installed headers thru sudo apt-get install linux-headers-$(uname -r). rebooted ubuntu. then ran sudo vmware-config-tools.pl. It still gives the same error when provide /usr/src/linux-headers-3.5.0-17-generic
    – user199627
    Feb 16 '13 at 5:53
  • nice job. worked a charm.
    – John
    Mar 29 '13 at 9:27
  • Still I am not able to get shared folder any idea why? Sep 13 '13 at 2:56
  • You're probably using a kernel that's too new for VMware. They only support old kernels without a patch to the VMware host and/or guest kernel modules. Almost every kernel version breaks the VMware modules in some way and they can't keep up. Sep 13 '13 at 14:00
  • @SatyamVakharia superuser.com/a/588307/144607 Sep 14 '13 at 1:33

I faced the exact same problem. I did all of the above and upgraded my installed packages. sudo apt-get update&&sudo apt-get dist-upgrade

sudo vmware-config-tools.pl was then able to automatically detect my kernel header files and completed its execution sucessfully. On reboot, I was able to see the HGFS mount and my shared folders.

  • I followed your steps too, but still not able to get shared folder .. any idea why? Sep 13 '13 at 2:57

The path you entered is wrong. The right path is /lib/modules/$(uname -r)/build/include/linux

See this post on AskUbuntu: what-is-the-path-to-the-kernel-headers-so-I-can-install-vmware.

  • Can you consider moving the information from askubuntu across to avoid link rot?
    – 50-3
    Sep 8 '13 at 12:49

Yes, note that /usr/src/linux-headers.... is not the kernel header vmware-config-tools is searching for, the real path is /lib/modules/$(uname -r)/build/include.

But yet it is better for the tool to find the path itself, so I recommend:

reboot your ubuntu and run all of these in sudo mode :

apt-get purge linux-headers-... (all versions you have installed already )

apt-get install --reinstall build-essential binutils

apt-get install --reinstall linux-headers-$(uname -r)

then again run /usr/bin/vmware-config-tools.pl and hopefully it will find the path this time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.