8

I just wrote a script through Automator to make a keyboard shortcut under the title "New Finder Window Home":

on run {input, parameters}

    tell application "Finder"
        activate
        make new Finder window to home
    end tell

    return input
end run

When I run the script from Automator, the Finder opens my home tab. Then I checked "New Finder Window Home" from System Preferences > Keyboard > Keyboard Shortcuts > Services and assigned ControlOptionCommandSpace as the shortcut.

Unfortunately, the shortcut is not working! Any suggestions?

| improve this question | | | | |
  • Works fine for me with other keyboard shortcuts. I'm guessing this is because there's simply no way to use ⌃⌥⌘␣ as a keyboard shortcut—at least not through the System Preferences. Maybe FastScripts works for you? red-sweater.com/fastscripts – slhck Feb 16 '13 at 20:33
5

Did you change the input type from selected text to no input?

If it's not that, there is also a bug on 10.7 and 10.8 where the shortcuts for Automator services don't always work until you hover over the services menu from the menu bar. It doesn't affect just new services, so it often makes Automator services unusable.

| improve this answer | | | | |
0

I also had the problem with the shortcut for Automator service and finally found that I already used this shortcut in Better Touch Tools that swallowed it silently. So, as and option for people who can't find why shortcut does not trigger it may be useful to check other running software that registers global shortcuts.

| improve this answer | | | | |
0

(macOS High Sierra 10.13.6)

I gave up trying to get an Automator script – either a shell (/bin/sh or /bin/bash), or AppleScript syntax, with input type set to no input and available to all applications) working with any keyboard shortcut - function keys or various letter/command/option combinations.

The script would run correctly within Automator, but either produced a beep or no sound at all when using the selected combination.

Additionally the shortcut wasn't always immediately visible, or took a couple of attempts to appear, when adding it System Preferences > Keyboard > Shortcut, so I'm not hugely confident about the reliability of that.

Also I had set the script to be visible to

Solution:

  • I installed the free version of FastScripts
  • I copied my AppleScript file to /Users/[myaccount]/Library/Scripts/ – the documentation isn't very clear - if you're trying to figure out 'how do I add a new script?' basically you need to copy it into that directory and it then appears in the UI, there's no New/Add/Create menu or button.
  • finally I specified the shortcut in FastScripts' preferences, by double-clicking on the Script.
| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.