8

In my new laptop I am using Microsoft Word 2003 SP3 running on Microsoft Windows XP in English.

Everything appears in English, and my default language in MS Word is English, which is fine since I write in this language. However, when I add a table, figure or equation to my documents, and create a Caption for it, instead of the usual "Figure", "Table", "Equation" words, I get the Spanish equivalents: "Ilustración", "Tabla", "Ecuación".

I have looked around and can't find a way to fix this. Any Help will be appreciated.

4 Answers 4

3

Here are two options depending on your situation:

Situation 1: Your copy of Office was installed from a Spanish language based install media.

You will be able to set the default language to English, but core functions will use the native language of the installation media.

The only fix is to uninstall the Spanish version, and install from an English-based install media.

.
.

Situation 2: Everything seems to be English, but occasionally foreign languages appear.

In this situation, here are repair instructions for Office 2002:

  1. Click the Start menu
  2. Point to Programs
  3. Point to Microsoft Office Tools
  4. Click Microsoft Office XP Language Settings.
  5. Click the Enabled Languages tab.
  6. Go to the Default version of Microsoft Office box
  7. Select the language you want
  8. Click OK. A message will appear telling you what changes will be made.
  9. Click Continue

I hope this helps.

2
  • I was exactly in Situation 2, and this worked like a charm. Frankly, I think this is the first time I use anything in the Microsoft Office Tools. Thank you! Oct 14, 2009 at 15:44
  • Does not work for office 2016. Jan 9, 2018 at 7:03
3

Adding a Fix 3 as I stumbled upon a similar problem just recently. This fix only works if, after setting your desired language, you still get captions in another one.

For me the issue was that all of a sudden (without any change of languages), my caption labels (and only my caption labels) changed language. The language for the captions is set in the "Normal" document template (a file with the ".dotm" extension). With Word closed, a quick delete of the document template (do back it up first!) will re-create it next time you open Word, and will re-populate the caption fields again with words from the set language.

Tip: Word keeps a set of "older" Normal document templates in the same folder (usually when a change occurs), so you can very well just rename the most recent old Normal template from before you experienced your issue, and all should be fixed at the next program opening.

You can check where is your document template for any of your documents by going to the DEVELOPER tab and clicking in the Templates panel the "Document template" icon. In the subsequent panel named "Templates and Add-Ins" if you click on the Attach button it will open the folder on your PC in which the word template resides. If you can't find your Developer tab, you can also go to Word->Options->Add-Ins->at the botton: Manage->select Templates->hit Go. Or do a quick online search for other ways to reach it.

Mine is called "Normal.dotm" and is located at: %appdata%\Microsoft\Templates

TL;DR : Reset your Word template either by deleting it (it recreates itself) or by renaming/choosing an older one from before your issue.

1
  • This method also works if you are not using the normal template but another one. For me the issue occurred when using sections. It was solved after doing what's mentioned in this post.
    – ThaNoob
    Apr 21 at 7:18
1

As Lucian commented, it seems that the language gets setup when Word starts. A trick that usually does work for me: close all instances of Ms Word. Open a blank document, right click the normal style and set the language of your choice (Modify Style/Format/Language).

You can then open the document you were working on, and the caption labels should show in the desired language.

-1

I find a solution. It's simple. I use Professional Plus 2019, but I think it works for other versions.

I think that the document configuration overwrites the program configuration. I'm using a document that has two languages, English and Portuguese and the label language was English as normal. One day I open the document and the label was in Portuguese, with the high inconvenience that the label number starts from 1 again. So I change the language of orthography of the whole page to English thinking that maybe some line in Portuguese could cause this change, but I didn't succeed.

The solution was to select all the document Ctrl+A and change to English using the bottom into the inferior bar. You select English, set as default and deselect the detect language automatically option.

Works for me, and you don't need to uninstall the whole Microsoft Package for this, as I saw as solutions. . . .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.