I have a Windows 7 machine connecting to a network via an ethernet connection ('Local Area Connection'). It connects up fine, gets an IP address, I can browse the web 100% fine and connect to printers and shared folders. Everything as you would expect.

However, the Network & Sharing Centre says that there are no active connections, and the network icon near the clock displays an icon I've never seen before - it has the Ethernet plug icon that says Ethernet is connected, but also has a small red cross in the lower right, not like the normal one. So for some reason Windows says the computer isn't connected to the Internet.

What this means is that we cannot connect to VPN connections. Windows says there is no Internet connection and wants us to use a dial-up connection to connect before it will do anything with the VPN. This is wrong, we have the Internet via ethernet and should be able to connect normally. The VPN is a PPTP one, if that makes a difference.

We've already tried a few things:

netsh winsock reset


netsh int ip reset reset.log

as well as restarting the computer (both before these commands and after). Neither of these worked, the problem remains.

So the question becomes: what do I need to do in order to convince Windows I have an Internet connection, so it will allow me to connect to the VPN connection?


1 Answer 1


For users trying to solve this same problem in the future, our issue was anti-virus related. We had both McAfee and AVG installed on the computer. Uninstalling McAfee solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .