I am using SSD with my laptop and running out of free space..

So I bought an 64GB microSD card as a secondary storage.

But, when I launch My Computer, the SD card drive is recognized as, of course, an external removable device.

And now, I want to change the SD card drive like a 'real hard drive' even if it's just a fake.

So, if there is any solution, please let me know.. Thanks a lot!

I tried mlink to make alias to my SD card. The alias was created perfectly but it couldn't fake the cloud storage service to recognize the mlink as a hard drive. nice programmers.. no fake allowed.. Does anyone know other options? Thank you.

  • What are you trying to achieve by doing so? – Der Hochstapler Feb 19 '13 at 18:32
  • 1
    @OliverSalzburg because of a cloud storage service. my cloud service only allows sync of local hard drives, not portable devices. any solution? thankx – klados Feb 19 '13 at 18:43
  • 2
    @klados symlink the card to some directory on your drive. Use command-line tool called mklink. – gronostaj Feb 19 '13 at 18:45
  • @gronostaj solved! great! not exactly what I wanted(making a hard-disk symlink), but it works. Thank you a lot. – klados Feb 19 '13 at 19:49
  • @gronostaj I'm here again. mlink worked perfectly but it couldn't fake my cloud service. it includes not only Dropbox but a few more minor services. Is there any other option? – klados Feb 20 '13 at 7:14

Have you tried to:

Option 1

  • Run > diskmgmt.msc

  • Select the disk you are trying to copy > right click > Change Drive Letter and Paths

  • Click on Add > Mount in the following empty NTFS folder

and follow the rest of the instructions?

Option 2

Another option - overkill as hell - is to use TrueCrypt to encrypt the removable disk and mount it as fixed (done by default).


  • YES!! It really works. At a glance, this method looks similar to the earlier one but totally different inside. Thanks @Andre de Miranda – klados Feb 20 '13 at 7:54
  • (still one of my cloud storages doesn't work that way but the others do) – klados Feb 20 '13 at 7:57
  • @klados I imagine you used the mount point option. Have you also tried using the TrueCrypt option? It is overkill but should work with all apps. – Andre de Miranda Feb 21 '13 at 4:05
  • yes that option works! but when I reboot, the cloud storage service starts before the TrueCrpyt mounting procedure. So, I gave up to use one of the services. Thank you. – klados Feb 22 '13 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.