ffmpeg.exe -i s.mp3 -f aac -

This is the command I run but it doesn't recognize the format AAC.

Requested output format 'aac' is not a suitable output format pipe:: 
Invalid argument

However when I run:

ffmpeg.exe -i s.mp3 -f ogg -

This works.

Also, outputting to a file like this works:

ffmpeg.exe -i s.mp3 o.aac

Any ideas what I'm doing wrong?


When you run this command:

ffmpeg.exe -i s.mp3 o.aac

you may notice the following line in the output:

Output #0, adts, to 'o.aac':

Here, ffmpeg is telling you that it is using the format called adts to generate an .aac file. Use -f adts instead of -f aac:

ffmpeg.exe -i s.mp3 -f adts -

protected by llogan May 8 at 17:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.