12

Until this morning, I'd been using sshfs quite nicely to mount a directory from a linux machine in my office. Today, it stopped. Here's my sshfs command:

sshfs -osshfs_sync,volname=linux-builder3 linux-builder3:/home/cnorum /Users/carl/linux-builder3

I get this error, but the sshfs process seems to still be running (that is, it just sits there, never returning to the shell prompt):

mount_osxfusefs: failed to mount /Users/carl/linux-builder3@/dev/osxfuse1: Socket is not connected

The system log on the Mac has these messages:

2/20/13 12:57:27.476 PM KernelEventAgent[43]: tid 00000000 received event(s) VQ_DEAD (32)
2/20/13 12:57:27.000 PM kernel[0]: OSXFUSE: force ejecting (no response from user space 5)
2/20/13 12:57:27.000 PM kernel[0]: OSXFUSE: user-space initialization failed (57)

And here's /var/log/auth.log on the linux machine:

Feb 20 12:56:28 linux-builder3 adclient[1599]: INFO  <fd:22 PAMIsUserAllowedAccess> audit User 'cnorum' is authorized
Feb 20 12:56:28 linux-builder3 sshd[29648]: Accepted publickey for cnorum from 10.0.40.65 port 49850 ssh2
Feb 20 12:56:28 linux-builder3 sshd[29648]: pam_unix(sshd:session): session opened for user cnorum by (uid=0)
Feb 20 12:56:28 linux-builder3 sshd[29729]: subsystem request for sftp

sshfs connections to other machines (linux-builder and linux-builder2 in my case) seem to be fine. Does anybody have any suggestions for what went wrong and how I might fix it? I can get any logs you might want to see!

4

For future googlers, I received this mysterious error and realized the path I was providing to sshfs was non-existent. Oops. Fixed it and I'm off.

mount_osxfusefs: failed to mount /Volumes/mypath@/dev/osxfuse0: Socket is not connected
  • This was very similar to my problem - I had a typo in the host address! Thanks! – IanW Apr 1 '15 at 0:12
  • in the same vein, I thought I could use my .ssh/config host synonyms in /etc/fstab definitions and without specifying an IdentifyFile=~/.ssh/id_rsa. Suffice it to say I was sorely mistaken! For the googlers I got (at least) a terse message in my syslog: OSXFUSE: user-space initialization failed (57) – lol Apr 25 '15 at 3:55
  • 1
    Note: ~/ on a mac is /Users/username/ but the linux computer probably has /home/username/. Once I changed sshfs server:~/ ~/mnt_fldr/ to sshfs server:/home/username/ /Users/username/mnt_fldr/ it worked. – David Oneill Jul 24 '15 at 15:59
  • Similarly, this error can be caused if the remote server cannot be connected to. – g.rocket Aug 8 '16 at 20:36
2

I think it's fixed. I had this line in the .bashrc on the linux box:

CLIENT_PATH_PREFIX="$(ssh ${CLIENT_ADDR} 'echo ${SSHFS_PATH_PREFIX}')/$(hostname)/$(whoami)"

It didn't need to be run by non-interactive shells, so I pushed that off to a different file, and it's better now. I don't really understand why, but I'm happy it works.

0

My problem was that the RSA host key for my host changed, so I had to run

ssh-keygen -R site.com
0

For me the problem was an offending key in known_hosts:

When I tried to SSH into the server, I received:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
SHA256:<something>
Please contact your system administrator.
Add correct host key in /Users/myuser/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /Users/myuser/.ssh/known_hosts:86
RSA host key for <server> has changed and you have requested strict checking.
Host key verification failed.

Removing the offending key (provided you trust the server), solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.