i have just downloaded Synergy and the 'server' computer will not start. All I get is a repeated message:

NOTE: connecting to service...
ERROR: ipc connection error, connection refused

I'm trying to connect 2 identical laptops running Windows 7 Home Premium.

When I run the server on the laptop I want to be the client, it starts straight away but the other still displays the same message and doesn't connect.

For some reason it also keeps telling me there is a new version out when I have the latest version. Also, in the 'about synergy' menu, it says "Version Unknown"

  • Did you check the windows firewall settings? Dec 28, 2013 at 23:36

5 Answers 5


I've had this problem as well, here is how I fixed it for me.


  1. Open your Windows Task Manager.
  2. Click on the Services tab.
  3. Right click on the Synergy service.
  4. Click Start Service.

I have had the the same problem.The only thing that seems to fix it for me is to uninstall the 64 bit version and install the 32 bit version instead.

(I am running Windows 7 64bit, that's why I tried the 64 bit version to start off with)

  • 1
    I've had a lot of issues with the 64-bit version of Synergy, installing the 32-bit version fixed all of them.
    – maxywb
    Jul 27, 2014 at 20:27

The Synergy Q&A has some answers to this question, did any of them work for you?


There seems to be a couple of potential causes:

1) You upgraded Synergy and the new GUI is having trouble connecting to the background service. You can fix this by opening a command prompt as Administrator and run the command

sc delete synergy

Then reinstall the latest version.

2) Alternatively, are you running Windows 7 32-bit? If you accidentally installed Synergy 64-bit, the GUI will run but the background service will not run (being 64-bit code). Even users of 64-bit Windows have reported that running the 32-bit version works better for them; they had problems with the 64 bit one, so give that a try.

If everything else is fine, finally try starting the service manually by pressing Windows-R, and then in the "Run" dialog typing services.msc. Find the synergy service in the list and tell it to Start. If it has errors starting, you should be able to see them here and post back with more info.


Thanks so much for this. The solution to delete the service and reinstall the 32bit version fixed the problem. It would be nice if the software could automatically recover from these issues.


I had the same problem. I realized that I had set the Synergy service in the MyComputer\Services to Manual.

So what I did is I go to MyComputer\Services, set back the Synergy service to Automatic, then I should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .