7

It seems that a Word document that contains some text that looks like an email address (e.g., joe@example.com) but that is intentionally NOT marked as a hyperlink, is turned into a hyperlink in the resulting PDF when saving as a PDF.

How can I save a Word document (using Word 2007) as a PDF and prevent any hyperlinks to be created?

(I am pretty sure that it is a hyperlink encoded in the PDF. As when opening the PDF in Adobe Acrobat 8.0, SumatraPDF or Google Chrome, all three viewers indicate a hyperlink when hoovering over the relevant email address)

Note - again - that they are never marked or shown as a (blue, underlined) hyperlink in the Word document itself. Only in the PDF they become clickable when you hover over them.

  • Rather than closing this question, answer it yourself so future visitors can reference it if they have the same question. – CharlieRB Feb 22 '13 at 12:47
  • @Rabarberski - Please remove the "answer" from your question and post the contents of the "answer" as an answer. – Ramhound Feb 22 '13 at 12:49
5

Hmm, seems I was wrong and that no link is created. In Acrobat's monstrous preferences menu, I just found on option under 'General' that says 'Create links form URLs'.

When unchecking it, there is no more link when hoovering.

2

In case anyone is having this issue in Word 2013 with images, when saving as PDF... I ran across this when looking for an answer to my embedded images displaying URL's to their original location when the document is converted to PDF. e.g. hovering over a picture displayed a non-clickable URL of, e.g. \NAS01\Photos\Repository\Etc.

When you save the file as PDF, click the Options button when you're selecting the destination directory and filename. Uncheck the Document structure tags for accessibility checkblock.

That worked for me. I did not have to update anything in the document itself, but, I do have to disable this checkblock every time I save the document as a PDF (the setting isn't persistent).

I hope that helps someone.

1

Select Word's Tools | AutoCorrect Options... menu item and on the AutoFormat tab in the dialog box, disable Internet and network paths with hyperlinks in the Replace section. If there are already some in the file, you'll have to manually remove them.

  • No, that doesn't work. Note that the problem is not that they are turned into blue/underlined hyperlinks in Word itself (they aren't). Only in the PDF they apparently are marked as a mailto: link. – Rabarberski Feb 22 '13 at 9:43
  • Wish you had clarified that in your question...as well as mentioned you were using Acrobat, because if you had I would have told you to change its Create links from URLs General Preference. – martineau Feb 22 '13 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.