14

When I open new PuTTY tab inside ConEmu Ctrl+Tab / Ctrl+Shift+Tab keyboard shortcuts are unusable once that PuTTY tab gains focus.

Is there any way to fix this?

I might be missing something obvious as I have been only using ConEmu for two days and I'm still trying to understand all configuration options..

1
  • Do you mind coming and accepting the answer given by Drew S? It is a straight solution without workarounds. – ᄂ ᄀ Feb 19 '17 at 21:27
15

When you run or attach any GUI application in ConEmu tabs – all keyboard input (read focus) passed to this child GUI application.

That's why Ctrl+Tab doesn't work in your case – it is processed by PuTTY but not ConEmu.

But there is a way.

Solution 1

If you have enabled option "Install keyboard hooks" on "Controls" settings page, hotkeys with the Win modifier are still working!  Even the focus is inside child GUI application.  By default you may use Win+Q and Win+Shift+Q to switch tabs. These hotkeys are defined on the "Keys & Macro" Settings page.

Solution 2

Go to "Keys & Macro" page, find row with "Set focus to ConEmu" description and choose hotkey, Win+BackSpace for example. Please note that some key-combos may not work – Windows captures many combos.

So you can press Win+BackSpace while keyboard focus is in PuTTY and after that Ctrl+Tab must work. You can try this with Notepad – keyboard focus will be more obvious.

5
  • Thanks, Win+Backspace combination is a nice workaround. And btw I'm on Windows 8 which maps Win+Q to Search Apps action so I'm unable to use special keys.. – krcko Feb 22 '13 at 16:25
  • 3
    You need to "Install keyboard hooks" on "Controls" page to make Win+Q working. – Maximus Feb 22 '13 at 18:10
  • I have "Install keyboard hooks" enabled, but I've disabled Win+Tab and Win+Numbers, as I use them a lot. I don't see Win+Q option though.. (I'm using 130220 x64 build). – krcko Feb 22 '13 at 19:22
  • Win+Q works for me on Windows 8 – Pavel Machyniak Jun 3 '14 at 8:38
  • Yep, Win+Q was already described. But I rewrite answer to make it more obvious. – Maximus Jun 3 '14 at 12:50
9

I found a way for this to work with Ctl+Tab.

Turns out I had Settings > Integration > Children GUI > 'Focus on child windows' checked. When I unchecked this option, I can now Ctl+Tab and Ctl+Shift+Tab insdie PuTTY

0

For anyone thats using Cmder (heavily based on ConEmu) there is built in functionality for using win keys to tab switch:

General > Support special hotkeys + Keyboard > Win+Tab - Switch consoles

This automatically overides windows and app keybinds, but the above issues with putty based console will continue and will not switch console window just console tab. There is no "Controls" settings page in Cmder to try solution 1 of this answer, but the solution I found was to DISABLE this setting:

Tab bar > Lazy tab switch

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.