I have an HP ProLiant server that is running Debian 5. After a reboot, it is not able to bring up any of it's interfaces. If I run ifup eth0, it gives me an error about the device not existing. (It has 4 Broadcom NetXtreme II interfaces.) I verified that it has a bnx2 driver (lsmod | grep bnx2). Then I tried unloading and reloading the driver (rmmod bnx2 && modprobe bnx2) and all of a sudden my interfaces work! Now I can ifup eth0 without any issues.

After restarting, though, the same problem arises.

My question is, can anybody speculate about what would cause a .ko to not work after a reboot, but then to work correctly after unloading and reloading it?

I'm guessing it's some kind of timing issue with the NIC hardware, or its a dependency issue with another .ko. Any ideas how to resolve it so that it will come up correctly after a reboot?


For Debian systems you can just add the module name to /etc/initramfs-tools/modules and then run update-initramfs -k all -u

  • Thanks, Rudy. Both good answers but my distro (which I failed to specify) was Debian. – Mark E. Haase Dec 19 '13 at 16:51

Appears to to be related to an incompatibility of the NIC. What Linux distribution are you using?

I came across the same issue on SUSE Linux. I got it to work by adding the bnx2 module /etc/sysconfig/kernel and regenerating a new initrd

If your distro is SuSE, add bnx2 in to the INITRD_MODULE list and then recreate a new initrd using mkinitrd

INITRD_MODULES="cciss jbd ext3 scsi_mod bnx2"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.