I have a 2TB HDD and first installed Windows 7 in a 1.8TB partition, leaving near 200 GB of unused disk to install Ubuntu in the future.

Yesterday I did that, creating 4 partitions:

  • 512 MB Swap
  • 350 MB /boot ext2
  • 16GB / ext4
  • The rest, near 180 GB, /home ext4

It went fine, installed, and restarted showing Grub with both Windows 7 and Ubuntu. I entered Ubuntu normally and worked fine but later I tried to enter Windows and it crashed. When restarted it shows a message saying "error, no such partition" and staying there. Here I noticed that this motherboard doesn't uses a BIOS, having instead UEFI, so perhaps GRUB isn't correctly installed.

Then I booted with the Ubuntu Live USB that I used to install previously and looking at the partition table (with GParted) and it shows this message:

/dev/sda contains GPT signatures, indicating that it has a GPT table. However, it does not have a valid fake msdos partition table as it should. Perhaps it was corrupted - possibly by a program that doesn't understand GPT partition tables. Our perhaps you deleted the GPT table, and are now using an msdos partition table. Is this a GPT partition table?

Only when I say yes it shows me the partitions, and there are 4:

  • swap 487 MB
  • ext2 334 MB
  • ext4 14.90 GB
  • ext4 1.80 TB

The Windows partitions have disappeared and now I cannot boot neither Ubuntu nor Windows.

How could I fix this without formatting everything?
Is there a way in which I could recover those old partitions?


Whatever you do, proceed with caution. You could make matters worse if you apply the wrong fix. Ideally, you should do a full low-level backup of the disk to a spare disk; but I realize this may not be practical with such a big source disk.

My first suggestion is to study my GPT fdisk documentation, and particularly the page on repairing GPT disks. The Wikipedia page on GPT is also worth reading. Once you understand the data structures, you'll be better prepared to attempt recovery. In particular, you can use the options on gdisk's recovery & transformation menu to load the backup GPT data, as well as the verify function (v on any menu) to get a more precise diagnosis of what is wrong with the disk. If you're lucky, you may find that your Windows partitions do exist in the backup partition table, and you'll be able to restore them by loading that partition table.

If you're unlucky, both your partition tables will have been damaged and you'll need to resort to a tool such as TestDisk to recover your data. (There are similar tools for Windows, but I'm not familiar with them, so I can't provide a link.) There's a good chance that TestDisk will be able to recover your partitions, but I can't make any promises about this.

My suspicion is that this was caused by a Windows program designed for use on a BIOS-based computer that wrote data "raw" to the disk into the area immediately following the MBR area. This area is officially unallocated, and so various tools have taken to using it as if it was their personal playground. The most common use is for boot loaders like GRUB, but even many non-system tools store data there. (IIRC, Netflix does this, for instance.) The problem is that on a GPT disk, this is where the partition tables are stored, so storing data in this area causes disk damage. If I'm right about the cause, this problem will recur unless you immediately identify and uninstall the offending software. You can simplify recovery by creating a backup of your GPT data using gdisk's b option on its main menu; if the disk is trashed again, you can recover by using the l (that's a letter L, not a number 1) option from the recovery & transformation menu.

Good luck!

  • Before trying anything with this gdisk tool (seems really useful) I tried that Boot Repair and it showed me this information: pastebin.com/Ff6YWxb2 For what I understand, I think that actually the Windows partitions are gone since in the sda disk there are only 4 partitions, one of which is 1.8Tb long, while the Windows partitions are from another sdb older disk (older because I know which other disk is). Am I right? – Ikzer Feb 23 '13 at 1:10
  • It looks like your GPT partitions still exist, but the protective MBR has been overwritten with a conventional MBR that doesn't include those partitions; however, based on your original post, it looks like the GPT partitions are all Linux partitions. It's unclear what's happened to your Windows partition. If you have no critical data on the disk, it may be simplest to wipe it clean and start from scratch. If you have data you need to recover, you'll have to proceed with gdisk, TestDisk, or other data-recovery tools. – Rod Smith Feb 23 '13 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.