22

I am logged in on my admin account. When I was trying to edit a python project using PyCharm (an IDE), it told me that the folder was marked as read-only (square box).

I open the folder in explorer, go to properties and uncheck read-only. I then press ok. I open the properties and it's set to read-only again! I looked up the folder hierarchy and all the parents are also read-only, all the way up to C:/. Any time I create a folder it's also set to read-only.

How can I fix this?

17

You will always see the Read-only box blue filled in the General Tab of the file properties.

The full situation is explained here: http://support.microsoft.com/kb/326549

This is an extract that gives the general idea:

Windows stores file and folder attributes in the file system with the file and folder name, extension, date and time stamps, and other information. The Read-only check box for folders is not available because it does not apply to the folder. You can use this check box to set the Read-only attribute for files in the folder. However, you cannot use Windows Explorer to determine whether a folder has the Read-only and System attributes set. To determine the attributes that are set on a folder, or to change these attributes, you must use the Attrib command at a command prompt.

I'm not sure what exactly is causing your problem but what you are describing in the folder properties is normal.

  • 1
    Of all the explanations I found searching online, this is actually the correct one. Unbelievably, MS found yet another way to shoot themselves (and us) in the leg! So many things were screwed up since Win XP. – ysap Aug 28 '15 at 16:30
  • FWIW in my case the problem was caused when antivirus software (BitDefender) started to block access to document subfolders without any notification.This appeared as a write error from the application. I assumed the filled in read-only checkbox was the cause. – Rattle Sep 18 '17 at 21:12
1

You could try probably right-click on the file go to properties. Then click on Security tab. There you can fing rules for System, owner, groups etc. So you could try change the read-only property there.

  • Under the Security tab you can find there also a table with read and execute, write, read, edit .... and for all these actions you have there allow and deny options. I wrote this only to clarify which part I mean. – Reshi Feb 23 '13 at 21:40
0

If you have the review panel open in Windows Explorer in the directory you are opening Word files from, this can cause files to be opened in read-only mode with no change to the apparent status of the Word file i.e. no checked "read only" box etc, although the file will have "(Read Only)" included in the title window above the ribbon. If you close the preview panel with the icon in top right corner of the folder's Documents Library your problem may very well be solved. This may apply to other file types as well e.g, Excel files. In fact, I have experienced a number of unexplained issues lately which seem to have disappeared with the closing of the preview panel - my machine is running a lot better now altogether. I am using Windows 7 Professional.

0

Building on the 'Security' tab idea, what I did was remove the CREATOR/Owner user and then I was able to delete the read-only folder with my regular admin priviledges.

  • Please read the question again carefully. Your answer does not answer the original question. – DavidPostill Jul 17 '16 at 10:22
0

I was able to change all settings for all users in Security tab for the folder Then I cleared Read-only box It allowed me to install into the folder

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.