34

I often have trouble with menu options staying on-screen after I click them. How to solve?

1

9 Answers 9

50

I've been having the same issue recently and it took me awhile to find this solution so hopeufuly it will help someone else too.

Restarting the Desktop Window Manager Session Manager (UxSms) seems to work perfectly.

Fire up a cmd prompt and run the following:

net stop uxsms
net start uxsms
4
  • 1
    This worked perfect
    – Brian
    Mar 27, 2014 at 12:09
  • 1
    This did not work for me.
    – dgo
    Jan 11, 2015 at 20:48
  • 1
    while this gets rid of the existing ones, it makes all future menus have a problem, unless I also use the solution from 3rdLion Sep 16, 2015 at 5:37
  • works like a charm
    – CDT
    Nov 3, 2017 at 2:48
31
  1. Control Panel > All Control Panel items > Performance Information Tools
  2. choose Adjust visual effects from the side menu.
  3. Uncheck "Fade out menu items after clicking".

The above process fixed it for me.

Obviously this is just treating the symptom and the real problem probably lies within the graphics drivers.

2
  • Trying it now. We'll see how it works. Aug 3, 2013 at 3:54
  • 2
    Haven't had any problems so far. Thanks for the fix! Aug 11, 2013 at 3:21
14

To remove the ghost menu-items, change the screen resolution and then change it back. This will cause the screen to completely redraw and remove the ghost menu item.

Easy way to change screen resolution:

  1. Right-click desktop and click screen resolution.
  2. Select a new resolution and click apply.
  3. Immediately click revert to get your old resolution back.
5
  • Do you have the latest video drivers installed? This is a workaround, not a solution for the actual issue.
    – Karan
    Feb 24, 2013 at 5:39
  • I use a restricted access account so couldn't use Rob's approach, but this worked fine thanks.
    – MattH
    Apr 29, 2016 at 10:33
  • 1
    You are genius. Oct 8, 2018 at 6:14
  • this worked for me in windows 10
    – Nando
    Jan 2, 2020 at 4:58
  • variation on the theme... changing the scaling and back
    – Mikey
    Jan 16, 2020 at 8:05
12

What I do in such cases is press CTRL-ALT-DEL, wait for the lock screen request, then return back to the original screen without locking.

3
  • 1
    I tried this first, but did not work for me
    – MattH
    Apr 29, 2016 at 10:31
  • Works perfectly, and simple Dec 16, 2018 at 20:08
  • Amazing - invoking "lock screen" works for me even on Macs! Thanks!
    – Hampden123
    Jan 3, 2019 at 13:12
2

Try pressing "F5" on the keyboard first- it might be all you need to do.

Edit:

Also try this: move cursor over item, hold the left mouse button down over any part of the menu (don't release) - move cursor away and off the ghost menu, THEN release the mouse. Failing that- kill Explorer in Task Manager and restart it again from the Run box (again in Task Manager).

4
  • Just tried it. It didn't work even when I had just clicked the ghost item. Perhaps I'm not doing something right? Feb 24, 2013 at 5:31
  • 2
    Ok nowwww I know exactly what you're talking about. I was wondering why I'd never experienced these on my Windows 7 system which I use constantly. But it turns out I see them all the time but didn't know they had a special name! Here's all you do to swat them away: - move cursor over item, hold the mouse button down over any part of the menu (don't release) - move cursor away and off the ghost menu, THEN release Now the spooky ghost item has gone and you won't be having nightmares anymore. Failing that- kill Explorer in Task Manager. Feb 24, 2013 at 5:46
  • I haven't had the issue recently, but this seems like the best solution. Could you make an official answer out of it so I can accept it? Mar 16, 2013 at 2:35
  • Sure! I'll append it to my original answer. Mar 16, 2013 at 2:40
1

Rob's answer of Restarting the Desktop Window Manager Session Manager (UxSms) using the cmd prompt works in the extreme cases. Its the last option I can think of before rebooting the PC/laptop. You can also reset the windows desktop manager using run window. Go to start > type run and open the run window. Type 'tskill dwm' to reset the windows Desktop manager. In normal cases going to lock window by CTRL + ALT + DEL and returning without selecting any option and changing the resolution/colour depth of the screen work fine enough and are the laziest options.

0
-1

Just press CtrlShiftEsc and kill dwm.exe. It will disapear.

1
  • I'm more focused on prevention here. I know how to fix it. Sep 5, 2013 at 4:09
-1

I came to this site to solve the same problem but actually ended up solving it myself(lol).

If you have windows XP then right click on the ghost menu icon and select open file location. This will take you to the startup menu files from where you can select and delete the ghost icon, or in fact, any startup menu icon you want to remove.

Hope this helped.

-3

What I did was made a text document and typed this (from an earlier comment):

net stop uxsms

net start uxsms

Then, I saved it as "gg.cmd" and found the file. I then created a shortcut called "Ghost" to remember it. Then I right clicked the shortcut and then clicked properties. Then I clicked advanced and checked "Run as Administrator" and hit "apply" and "done". That's it! Just click the shortcut and it fixes it! You can put the .cmd file in another folder but don't delete it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .