I had Ubuntu 10.04 running. I created a software raid 0 with 3 drives.

Today I upgraded to Ubuntu 12.04 (actually a fresh install) and now I am facing a huge problem:

I cant reassemble the raid, because appearently all superblocks are gone. I tried

sudo mdadm --assemble /dev/md0 /dev/sdb /dev/sdd /dev/sde

No luck. dumpe2fs shows only for one drive (sde) some raid information like stride and stripe information.

mdadm --examine only shows "no md superblock detected" Unfortunately, I cannot make 1:1 backups of each drives because, I simply don't have any drives to spare. So I can not really play around and hope that it works.

Is it still possible to reassemble the array without dataloss? Thx.

  • Possibly useful information: askubuntu.com/questions/69086/mdadm-superblock-recovery
    – Hennes
    Feb 24, 2013 at 19:26
  • RAID 0 does not allow for a single drive to fail. You don't really have options. RAID 1 and RAID 1+0 would have allowed for data recovery. You can read more about your future options here: en.wikipedia.org/wiki/RAID#RAID_0
    – Ramhound
    Feb 24, 2013 at 20:04
  • But the data itself should be fine... should be just a matter of telling mdadm that there is a raid on the drives and it just has to be assembled somehow
    – Pythoneer
    Feb 24, 2013 at 20:17
  • @ramhound True RAID 0 does not allow for any drive to fail. But the no superblock detected message can have several reasons. One is a problem with using the whole drive rather than a partition in such a way that both the RAID signatures and the drives partition tables space overlap. That can work, assuming your bootloader recognises the RAID part and correctly parses it. With the upgrade the bootloader might have gotten written. So no actualy drive hardware failure is needed to run into problems.
    – Hennes
    Feb 24, 2013 at 21:48
  • I tried something in Hennes' link above. Using --create or --build I can create a raid md0 and it seems to run, but I cannot mount it. When I use --create, I get the message that it does not appear to be ext2/3/4, if I use --build it says "unknown filesystem type "linux_raid_member""
    – Pythoneer
    Feb 24, 2013 at 22:28

1 Answer 1


Ok, I managed to solve this pickle. I'll write it down, so others, who might have the same problem, can try it.

I found a software called ReclaiMe Free Raid Recovery. Its for Windows, and its free. After you tell it which drives were in the raid0, it scans around, depending on the size, for sever hours. For me it took about 2 hours until it was confident to have found the correct parameters for the raid0.

And so it did. It found them, and then it can either open up recovery software, or just tell you the parameters. With those, I've gone back to linux and used

mdadm --create -l 0 -n 3 -c 64 -metadata 0.9 /dev/md1 devices

The crucial thing here was the metadata number. Apparently it defaults to 1.2, but my raid hat 0.9. So I basically tried them out and used fsck to see if it works. With 0.9 it found a filesystem which appeared to damaged.

Using e2fsck, it corrected a bunch of errors in inode 7. At one point, I cancelled because it seemed to do nothing. But after that I was able to mount it.

All files are there. I copied important stuff right away to another drive. All files I tested are working properly. The Raid has been restored.

Although there still seems to be something wrong in the filesystem, because

df -h

shows that I am usung -27 GB :)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .