Today I faced a situation I'm not clear how to try to get around. I will have to perform a maintenance operation on a pair of Win 98 computers weekly. In that operation I will need to input and output data, so the preferable option is to install USB drivers (currently not installed) and then work always through USB from inside Windows. Both workstations are old have about 10 years old motherboards. Sorry in advance for long introduction.

When I wanted to install USB drivers I realised that one of them's optical drive does not work. I have no diskettes. I tried to boot from a Hiren's Boot USB flash drive. One of them went perfectly: enabled USB boot, flash drive showed under "Hard Disks" (xD), set flash drive with first priority, booted into it. But exaclty the one which optical drive is broken fails to do that: boot from USB option is enabled, flash drive shows as Hard Disk, but when it tries to boot form it screen says: "Boot failure.", then boots from HDD.

In which direction should I go to try to solve this? The real question is: if that motherboard was intended to boot from USB device, what has changed about motherboards internals since the last ten years about the issue? Have the number of different USB device interface grew and may an old motherboard not recognice a particular flash drive (so I should try another flash)? May be a architectural limit in the motherboard when it comes to handle an 8GB flash drive (so I should try a smaller one)? Have the types of boot sectors formats evolved in the last years (so I should choose a different boot sector type when I create the bootable Hiren's flash)? Is there any other important point about USB interfaces internals I am missing?

I'd love to find someone that could provide good references or increase my aknowledge about the issue. Best regards.

NOTE: I've already read "cannot-boot-to-usb-with-pcchips-a13g-motherboard"

  • 1
    Check the BIOS and enable options for (Legacy) USB support, USB booting, USB HDD support and so on. USB booting is dependent on the BIOS, and many old MBs did a bad job and had lots of bugs/quirks. Yes, I would recommend trying a 1GB or even smaller USB stick if available, and use FAT32 preferably instead of NTFS. Also check if any BIOS updates are (still) available. – Karan Feb 26 '13 at 0:04
  • 1
    Two things really - I've had specific USB drives that refused to be bootable on specific systems, and never quite worked out why. The other is the first sentance of your second paragraph seems broken, I suspect, much like your optical drive. I'll edit to make it clearer, but if I'm incorrect feel free to roll back – Journeyman Geek Feb 26 '13 at 0:04
  • @Karan, I already enabled all these options. USB emulation mode didn't exist on the problematic motherboard - but it did in the other. BIOS upgrading is not an option, it's still preferable replacing the optical drive. I'll try with different flash drive as you say and I'll post back the results. – Áxel Costas Pena Feb 26 '13 at 8:33
  • @JourneymanGeek, thank you for your edit, I always review my posts before saving and I never notice the bugs I've made :( thank you for your experiences – Áxel Costas Pena Feb 26 '13 at 8:34
  • Well, after a time in which I could not go ahead, I've tested it with a 1GB pendrive, and I moved a little forward. Now the error is "cannot find MBR helper" (this time it was a 1GB pendrive so I had to use standard version of Hiren's). The main difference wasn't the size of the pendrive but the kind of boot sector. So the motherboard won't boot SYSLINUX, but it will try to (and fail to) boot MBR. Is there any kind of boot sector format which is more "old hardware friendly"? I thinked MBR was the most extended... – Áxel Costas Pena Apr 1 '13 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.