Whenever I open up an Explorer window, and click on the "Desktop" icon, "Libraries" is always selected in the files list.

What, you don't think that's a problem? Look at this:

Goddamnit, Libraries!

Because Libraries is selected, the list of files is always scrolled to the bottom. Because I like my desktop sorted by date, I always have to scroll up to get to the files I wanted to get to. This is particularly aggravating whenever I'm using an open file dialog, as the files I want to open are newer and therefore at the top of the list.

I've asked other people if they experience this behavior, and the answer has always been no.

What could cause this to happen, and how do I stop this?

(Note: I'm sorting by date descending, and grouping by date. Changing this does not alter the problematic behavior)

  • 3
    I don't think Madden could have drawn up that any better :). – Brad Patton Apr 26 '13 at 0:26
  • +1 for explaining that it IS a problem because it bugs you for (any) reason. For the record, on my system, My Computer is always selected, not Libraries. ಠ_ఠ Anyway, just another reason to disable the stupid navigation pane that only takes up space for nothing. I suggest using Clover and enabling the favorites bar instead. – Synetech May 1 '17 at 14:01

I've been searching for a solution to this exact question. I place all of my recent and to-do files directly on my desktop and need quick access to them in a details view format. To access the files, I use Windows Explorer from the taskbar then click Desktop which also ends up highlighting and selecting Libraries by default and then requires scrolling -- really annoying.

I stumbled upon a work-around that may work for you. Pin the Desktop icon to Windows Explorer on the taskbar. Then whenever you need to access the desktop you have to right click the Windows Explorer icon and then select Desktop. In this method Libraries is not selected and you can select your files by date with the most recent files showing at the top. It works for me although a more direct single click folder view of the Desktop would be ideal.

BTW- this issue seems to also exist when you access the Desktop folder through Computer, a users profile name, Network, and Homegroup. So basically whichever link you select just prior to clicking Desktop will get selected and highlighted in the Desktop view. Perhaps searching for a solution to these similar (if not the same) issues, may reveal a different solution than I provided.

|improve this answer|||||
  • Look, I don't care if you have Angelina's blood in a vial around your neck, but this is at least something. I still want a 100% fix for this BS. And, I'm sure, so do you. I will see if this is acceptable in practice. I don't feel so, unfortunately. – user939 Apr 26 '13 at 4:55

I'm sure there's a small thing I'm missing that would probably clean it up, but try this:

  1. Open a privileged (administrator) cmd window:
    • Start Menu, type cmd, right click cmd.exe, Run as administrator
  2. Change directory to the one you want the link to be created in (Favorites):
    • Type: cd %userprofile%\Links
  3. Create a directory link to Desktop:
    • Type: mklink /d "FixedDesktop" "%userprofile%\Desktop"
  4. Run Explorer, and click on the Favorites (star) folder.
  5. Drag and drop the FixedDesktop folder into the Favorites list.

    enter image description here

    • This will make it a shortcut to the newly linked "FixedDesktop" directory.
    • If you don't do this, FixedDesktop won't appear as a shortcut in the Favorites list.
  6. Delete the old Desktop link out of Favorites, and rename FixedDesktop link as you see fit. You can change the icon, too.
  7. Celebrate victory.

Voila! The Desktop shortcut in Favorites will now remember your view settings. Yes, you'll have the symbolic link folder to your Desktop just sitting in Links... But it won't do anything and won't show up in the Favorites list, unless you manually open it from within the Links directory.

|improve this answer|||||

Try creating a new desktop icon for your favorites list, that did the trick for me.


This is what I did. When using this new link, I don't even have a libraries folder on the desktop now.

enter image description here

|improve this answer|||||
  • Nice suggestion (hadn't tried this), however it hasn't worked. – user939 Feb 26 '13 at 14:48
  • @Will should have said desktop shortcut, but a picture's worth a thousand words. – MDMoore313 Feb 26 '13 at 14:57
  • Nope. A picture isn't worth jack in this case, as it still doesn't work. Tried about five different ways to do this, and no matter what my favorites desktop icon is different from your second desktop icon and it still fails. Not sure why. Also tried changing the icon to point to explorer.exe c:\users\me\desktop, tried just explorer.exe but had the startup folder set to my desktop (even worse--it starts up in Libraries! Its mocking me!), etc etc. So if you're doing something special here you're going to have to spell it out, as I can't guess what it is. – user939 Feb 26 '13 at 15:14
  • @Will Scratch my last comment: I clicked on the original desktop icon in my favorites, then double clicked on my profile folder on the desktop, then dragged the desktop shortcut from THERE to the favorites list. Sorry for the confusion, I thought it was the same thing but apparently there's a difference, I just retraced my steps. – MDMoore313 Feb 26 '13 at 15:31
  • Nope. Doesn't work. Something else is happening here. The link created when I drag has a different icon than yours, and the location bar just shows Desktop, where yours shows (I guess) your profile folder name THEN Desktop. Here's +1 for your efforts, tho. – user939 Feb 26 '13 at 17:30

Okay, this works for me (Windows 7 64b SP1). In a console enter the following:

pushd %userprofile%
mkdir /d OrderlyDesktop Desktop
start . 

Drag and drop from the opened Explorer to add the OrderlyDesktop to the Favorites. Use this link to quickly navigate to your Desktop and keep sorting intact.

|improve this answer|||||
  • Thanks @Doktoro Reichard, i'll keep your changes in mind when posting next time! – Remco Apr 23 '14 at 12:23

IF you right click on the windows explorer (folder) icon in the task bar you will get a list of frequent folders that show up. Under those is also an additional windows explorer icon, right click on that and go to properties. In the "Target:" slot you should see %windir%\explorer.exe. To fix this issue click on this slot and add a space to end along with the file path to your desktop. So since my username for my computer is Isaac, my "Target:" slot reads %windir%\explorer.exe C:\Users\Isaac\Desktop. This fixed the issue for me, and the Libraries folder is no longer selected when I open the windows explorer.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy