24

I'm putting together some documentation and don't have access to a non-configured machine to test this myself

I'm curious if you need a GitHub account to clone a repository from GitHub to a local machine.

migrated from stackoverflow.com Feb 26 '13 at 22:15

This question came from our site for professional and enthusiast programmers.

33

No. You just use a different URL:

git clone git://github.com/SomeUser/SomeRepo.git

However, the local repo will be "read-only" in the sense that you won't be able to push your changes back to the original repo. You will still able to modify files and commit changes locally, though.

In contrast,

git clone git@github.com:UserName/OtherRepo.git

works only if you have properly set up your environment with the necessary SSH keys and whatnot, but in return you'll get a repository that permits you to commit/push the changes back to the remote repo.

(Sorry for the unintentional ad for GitHub, I just had it in mind.)

  • Awesome, thank you for the clarification. I'm aware of the limitations by approaching a clone this way, but it's fine for the context of the process I'm documenting. – Joseph Mainwaring Feb 26 '13 at 20:29
  • @JosephMainwaring I'm glad to have helped. Please don't forget to accept my answer when you'll be able to do so. – H2CO3 Feb 26 '13 at 20:30
  • For GitLab it's git clone https://gitlab.com/SomeUser/SomeRepo.git – Matthias Braun Jun 6 '17 at 9:46
2

I was following some documentation for a product which required cloning from github. I didn't want to bother setting up an account so I needed to do exactly what was asked here.

The command in the documentation was:

git clone git://github.com/fcrepo4/fcrepo-message-consumer.git

but that just fails for me with.

Cloning into 'fcrepo-message-consumer'...
ssh: Could not resolve hostname github.com: nodename nor servname provided, or not known
fatal: Could not read from remote repository.

I tried

git clone git://github.com/fcrepo4/fcrepo-message-consumer.git

as suggested in one of the answers but that failed too with.

Cloning into 'fcrepo-message-consumer'...
fatal: Unable to look up github.com (port 9418) (nodename nor servname provided, or not known)

What finally worked was this:

git clone https://github.com/fcrepo4/fcrepo-message-consumer.git
0

Or just use http prefix , and .git suffix is not mandatory too :

You can check with

git clone http://github.com/tizenteam/iotivity-example

Related info:

https://help.github.com/articles/why-is-git-always-asking-for-my-password/

  • Anonymous download actually wouldn't work for me until I removed the .git suffix. – jhfrontz Jun 8 '18 at 14:42
0

You could use Github Tokens https://github.com/settings/tokens and use this:

git config --global url."https://${GITHUB_TOKEN}:x-oauth-basic@github.com/".insteadOf "https://github.com/"

(replace ${GITHUB_TOKEN} with the actual token

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy