I've added my Gmail to Outlook 2013 via IMAP. Now whenever I compose an email, if I let it wait for a while, it saves a copy to my IMAP drafts folder. However, when I send the message, the message gets sent but the message in the drafts folder still remains! Eventually this has let to my drafts folder being useless because it doesn't have just drafts - it's got a lot of work-in-progress emails that aren't drafts (i.e. too much noise in my drafts!)

How can I setup Outlook so that when I send the email, it is cleared out of drafts?

  • Sounds like this is a problem with the server side more then Outlook itself. You can attempt to verify this problems exists in Thunderbird I suppose. Your only other alternative is POP3 mails since free Google Mail accounts don't support Active Exchange Sync anymore.
    – Ramhound
    Feb 27, 2013 at 13:06
  • Having this same problem with Outlook 2013 and a Postfix IMAP server. Outlook seems to save multiple copies of drafts after modification and if they get sync'd to the IMAP server they are not deleted when sent.
    – Farray
    Apr 1, 2013 at 20:03
  • I can confirm this is an issue with Outlook - Gmail is fine. Funny how Outlook 2010 worked fine, innit? :/
    – MBender
    Jun 12, 2013 at 9:36
  • Outlook 2013 personally works fine for me.
    – Ramhound
    Aug 21, 2013 at 2:29

5 Answers 5


When Outlook connects to Gmail via IMAP, Gmail instructs Outlook where it wants it's drafts stored. But because Outlook handles drafts differently to what Gmail expects (i.e. local handling rather than IMAP-friendly), draft copies can remain on the server even once the email is sent.

You can resolve this by having Outlook use a local drafts folder on the computer that Outlook is installed on, rather than the Gmail drafts folder.

Right-click on a folder within the IMAP account you are using. Select "IMAP Folders...". Select the "Subscribed" tab and click "Query".

In the list of results, select the Drafts folder and click "Unsubscribe".

You should see the "Drafts" folder in Outlook replaced with a folder labelled "Drafts (This computer only)"

Note that (obviously) this will mean that drafts on that computer are now no longer synched up to Gmail, so you won't be able to access and complete those drafts via the web interface or from another computer.

  • This should be marked as the answer. Jul 10, 2014 at 3:52
  • 2
    In Outlook 2013, I get an error "Cannot unsubscribe from folder. '[Gmail]/Drafts' is a special folder and cannot be unsubscribed from in Outlook." Jun 11, 2015 at 15:00
  • I have the same problem, I cannot unsubscribe from the [Gmail]/Drafts folder for the same reason.
    – olee22
    Aug 21, 2015 at 19:45

Since I cannot comment due to low reputation I will post here.

I tried the first accepted solution above and got an error: "Cannot unsubscribe from folder. '[GMail]/Drafts' is a special folder and cannot be unsubscribed from in Outlook."

As an alternative I went to GMail via the web interface. I then went to setting (button on top right of message list) - then to the Labels tab. Uncheck the drafts folder "Show In IMAP" option. This is the same as unsubscribing from the folder via Outlook.

This fixed the issue for me.

  • Unfortunately this isn't great for mail clients that actually work correctly with Drafts, like my iPhone and iPad. Jun 11, 2015 at 15:00

I got resolution for the files not being able to be deleted from the DRAFTS folder. I have a one-year Microsoft Assure plan so I just talked with Microsoft support on this issue. I had already looked and/or tried different "fixes" for this Outlook 2013 IMAP DRAFTS folder issue from internet search results (included the "fixes" post on this site) but without success.

My situation is that I just moved from Windows Vista/Outlook2007 to Windows 8.1/Outlook2013. I started having files remain in the DRAFTS folder after after sending the email for which the file was a draft. I had the same problem if I moved the draft to other folders or even after trying to delete the draft out right. In each case, copies would show up in the DELETED or other folders but the original would remain in the DRAFTS folder. I did not have this issue when I was using Windows Vista and Outlook 2007.

I was a little skeptical that the Microsoft fix would work and concerned that I might lose some email in the process. However, it did work just fine and my email files are fine.

The answer from Microsoft for my particular issue that I mentioned above was to:

  1. Open "Account Settings"
  2. Highlight the IMAP account you're having problems with
  3. Choose "Change" on that menu (opens the "Change Account" window). Everything on this screen should be okay
  4. Click on "More settings..." (it opens the "Internet Email Settings" window)
  5. Go to the the "Advanced" tab
  6. Go to the "Folders" section of the window
  7. In the field following "Root folder path"...type in the word "inbox"
  8. Choose "OK" (closes the "Internet Email Settings" window)
  9. Click "Next" in the "Change Account" window (opens the "Test Account Settings" window and run a test)
  10. Close the the "Test Account Settings" window
  11. Click "Finish"
  12. Close the "Account Settings" window
  13. Close and reopen Outlook.

I suggest closing Outlook in step 13 because in our first test to see if it worked the files in the DRAFTS folder did not immediately go away (even accounting for the IMAP standard sync delay) and also after pressing "Send/Receive" email. So, we closed Outlook, reopened it, and the DRAFTS folder was empthy. I then did a few more tests saving drafts, sending email from drafts and deleting drafts and the tests all worked fine. My DRAFTS folder was empty when it was supposed to be and had contents when it should. As an additional note, I have subsequently save some emails to DRAFTS and so far they are persisting in DRAFTS until I reopen and send them or or until I specifically delete them from DRAFTS.

  • UPDATE: This is a followup. The methodology that I posted above on 09/24/2014 failed shortly after my pose. A technician at my IMAP mail services provider had me delete the profile (after making a redundant copy of the IMAP mail folders to a local PST) and recreate the profile. This recreation of the Outlook desktop profile to access the email in the IMAP account has held up fine for about a week. The local PST backup, while a good safeguard, was not needed since the IMAP server correctly and completely synced all of my messages to the new local IMAP account in Outlook. I hope this helps.
    – LTP
    Oct 1, 2014 at 1:52

Try using Google Apps Sync instead. I started using that instead of IMAP and it works great. https://tools.google.com/dlpage/gappssync

  • This tool will not work with free accounts unless you set it up before the cut off date.
    – Ramhound
    Aug 21, 2013 at 2:30
  • I was surprised to see the tool actually works great. It probably won't work for a free account, but for G suite users it does. setup is easier than IMAP and so far no issues.
    – OSH
    Sep 23, 2020 at 22:23

Thanks for all the help, but I found another reason this can happen and wanted to let future users know. I'm just finishing an email migration from [other email provider] to G Suite and several users use outlook and have for many years. Part of the migration was importing the many gigs of PST files from the last decade or two. Inside those folders, there were other folders labeled "Drafts" (which upon import becomes labels in gmail). Having another folder named "Drafts" made gmail show the built in one as "[Gmail/Drafts]". I renamed the old drafts folder from the PST import to "old drafts" and gmail reverted its built in label to "Drafts" and outlook started functioning properly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .