15

I can't use the Windows 7 File Explorer search successfully. If I enter a search string, for instance car in the search box, I just get No files found, despite obviously having several files that match the string (blue_cars.jpg, carrot.gif) in the current folder. I have edited the search options so that both file names and contents are searched, even if they are not indexed.

What am I doing wrong here?

  • I am not allowed to post answer for some reason but I have an answer that worked for me. 1. Go to control panel and search for "find and fix problems with windows search" 2. When it pops up click "Advanced" click Run as Administrator 3. On the next screen hit "Files don't appear in search results" After running this, it immediately started indexing. – DisibioAaron Jun 28 '16 at 1:30
5

I think you search some thing that windows 7 indexing not working on it. Go to the control panelindexing optionsSelect Modify and select any location for indexing because windows explorer use indexing to find data on the computer.

I recommended to use Total Commander as file manager that has many many features specially great file search tool.

| improve this answer | |
  • 3
    Thanks, but my drive is already indexed. And in Search options, I have selected that even non-indexed folders should get searched. I agree with you that tools such as Total Commander or FreeCommander are vastly superior, but it would be more convenient if Windows' inbuilt functions actually worked. – Gruber Feb 27 '13 at 11:57
  • 1
    did you try to rebuild indexing database? some time rebuild database can help around this issue. – Kaveh Feb 27 '13 at 12:05
  • 3
    Wow, that actually worked, despite the setting that the index should be ignored. That seems like a bug to me, and it's strange that Windows doesn't default to a simple recursive directory search if the index is not usable. – Gruber Feb 27 '13 at 15:50
  • Rebuilding the indexing worked for me. – Martin Feb 26 '19 at 13:13
6

Rebuilding the indexing database worked for me! Rebuild it from zero. Then try.

To rebuild it:

  • Click Start
  • Search for "index" and then select "Indexing Options"
  • Click "Advanced".
  • Click button that says "Rebuild" and it will delete and rebuild your index file.
| improve this answer | |
  • 3
    Can you expand on your answer and explain how to rebuild the indexing database? What steps should he take? – user201262 Oct 7 '13 at 14:21
  • If I remember correctly you can click Start, search for "index" and then select "Indexing Options", then click "Advanced" and then you'll see a button that says "rebuild". Click that and it will delete and rebuild your index file. – Lil' Smokey Dec 31 '13 at 6:41
5

In Windows Explorer search box prefix your search with name:

i.e. name:car

Don't ask me why it does not find files by simply typing in just car, it' s just another Windows' oddity.

enter image description here

| improve this answer | |
1

First you have to check the Index of the Drive is checked or not

enter image description here

After that you have to start the searching and after that you found the problem than make sure that the file you are searching is there in that drive

| improve this answer | |
  • 1
    Thanks for the tip. I had it checked, and besides I have the setting that even non-indexed places should be searched. I must say I am disappointed that Windows' inbuilt search is so lacking in usability; I remember back in the XP days it didn't work either: you had to add file extensions to the registry for Windows XP to recognize a file and search it. – Gruber Feb 27 '13 at 12:00
  • There is lots of trick you can do beside that also there is many search tool that from Windows only that will work awesome one of them are like Desktop Search and Window search and many... – SaviNuclear Feb 27 '13 at 12:09
0

Make sure that you have the Windows Search Service enabled. If it is not enabled, indexing will not be available and File Explorer will not give you an error.

You can enable it (or check it's status) in one of two ways:

By running services.msc

  1. Run services.msc (from the run window, Windows+R and enter services.msc)
  2. Double-click Windows Search in the list
  3. Change the Startup Type to "Automatic (Delayed Start)"
  4. Click the Start button

From an elevated command prompt

  1. This gives you a higher permission level to start and stop services, among other things. Here are two different ways to do it:

    • Press your Windows key and type cmd, then hold down CTRL+ALT+SHIFT and press ENTER, or
    • Press your Windows key and type cmd, then right-click and choose "Run as Administrator".
  2. In the command box, type net start wsearch and press enter. It should respond with:

    The Windows Search service is starting.

    The Windows Search service was started successfully.

At this point, you should see folders listed in the indexing Either of these ways will start the Windows Search Service.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.