After googling for days and trying 1001 solutions, I decided to post here for further advice. I have a Nexus 4 phone, Windows 7 x64 Ent with latest updates, google USB Driver installed.

My phone appears in device manager as an Android Device, but not under Portable Devices, and nothing in My Computer in windows explorer.

enter image description here

I have tried in my laptop with the same windows etc, and it works fine there; in that case, the "Android Device" entry is missing, but the phone appears instead under Portable Devices and I can access it through windows explorer as if it was another drive.

With the above said, I discard any issues with either the cable or the phone setup.

Any ideas?

Update: trying the following guide http://www.londatiga.net/it/how-to-use-android-adb-command-line-tool/

when i type "adb devices" it doesn't find the Nexus:

enter image description here

  • Do you want adb or storage, adb is really only for hacking, debugging and developing on the device. The issue you're having regarding storage is most likely because you have different drivers installed.
    – Jay Wick
    Mar 4, 2013 at 8:28
  • I want storage. At first it wouldn't install, saying it couldn't find any drivers, then I tried with both the Google USB driver from the SDK and the "Naked" drivers, both of which end up with the device listed as ADB. But even like that, the adb tool says there is no device attached.
    – hikari
    Mar 4, 2013 at 11:39
  • @jay ADB is good for more than only for hacking, debugging and developing on the device. It's also good for backups (at least with Android 4.0 and higher, see Full Backup of non-rooted devices), and can be used to manage your device (take e.g. a look at QtADB). It even permits you to access your storage without having it unmounted from the device. And you can install/uninstall apps this way, plus much more.
    – Izzy
    Jun 1, 2013 at 17:51
  • @Izzy Of course. Sorry I meant 'hacking' in an extremely broad sense in this context just meaning 'not storage' for average users. Never knew about QtADB, thanks for that! :)
    – Jay Wick
    Jun 4, 2013 at 7:02
  • 1
    You're welcome, @jay! Besides, if you're on Windows, there are even other great tools to maintain Android devices via ADB, like e.g. DroidExplorer by our ASE-fellow-member Ryan Conrad (should even run on Linux using Mono), listing features as e.g. Access files in other directories besides SD card and Copy files from device to local clipboard plus vice-versa, Screencast, and more :)
    – Izzy
    Jun 4, 2013 at 7:47

3 Answers 3


Fixed it


  • I uninstalled
  • Reinstalled with Naked drivers
  • Opened device properties, update driver
  • Pointed to naked driver folder
  • Picked "Let me pick from ..."
  • Chose "MTP USB Device", from "Standard MTP Device" category

I don't know why this worked now, I tried this before and it would take a while..20-30 seconds and then say the device could not start, but now it works somehow.


Go to setting in your phone ( Nexus 4) => storage => click on options on the top right corner of the screen and choose "USB computer connection" => select FIRST option OR if you want to use Camera select second one. ;-)

Bests Saman.


Windows 7

To install the Android USB driver on Windows 7 for the first time:

Connect your Android-powered device to your computer's USB port.
Right-click on Computer from your desktop or Windows Explorer, and select Manage.
Select Devices in the left pane.
Locate and expand Other device in the right pane.
Right-click the device name (such as Nexus S) and select Update Driver Software. This will launch the Hardware Update Wizard.
Select Browse my computer for driver software and click Next.
Click Browse and locate the USB driver folder. (The Google USB Driver is located in \extras\google\usb_driver.)
Click Next to install the driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.