21

I have been searching for a while, but I don't find a solution for this anywhere... I'm in a factory and they have Windows Server 2012 with an HMI (HumanMachineInterface) on it. They have computers that they can log on the server to access the HMI. However every 15 minutes they are logged off of their session automatically. This is really annoying because they have to do it 50 times a day.

How can I disable that feature?

14

Quoting from Technet:

To specify timeout and reconnection settings for a remote session:

On the RD Session Host server, open Remote Desktop Session Host Configuration. To open Remote Desktop Session Host Configuration, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click Remote Desktop Session Host Configuration.

Under Connections, right-click the name of the connection, and then click Properties.

In the Properties dialog box for the connection, on the Sessions tab, select the following options as necessary:

Select the Override user settings check box, and then set timeout settings for End a disconnected session, Active session limit, and Idle session limit.

Select the Override user settings check box, and then select one of the following reconnection settings: Disconnect from session or End session.

Click OK.

Changes to timeout and reconnection settings are not applied to sessions that are connected when the change is made. The changes will take effect the next time the user establishes a new connection to the RD Session Host server.

You can also configure timeout and reconnection settings by applying the following Group Policy settings:

  • Set time limit for disconnected sessions
  • Set time limit for active but idle Remote Desktop Services sessions
  • Set time limit for active Remote Desktop Services sessions
  • Terminate session when time limits are reached

These Group Policy settings are located in the following locations:

Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

These Group Policy settings can be configured by using either the Local Group Policy Editor or the Group Policy Management Console (GPMC).

| improve this answer | |
  • @Speccy, given you accepted this answer the day after your above comment: can we assume this worked for you? (I know, it's been a while...) – Arjan Jul 25 '14 at 15:57
  • imgur.com/a/cUcWq – Luke Apr 8 '18 at 12:38
  • I don't have Remote Desktop Services in Administrative Tools, do you have any idea about this? – Luke Apr 8 '18 at 12:38
  • 2
    after a few search, Microsoft confirmed that Remote Desktop Services has been removed from Administrative tools from windows server 2012, It's being managed in Server manager, do you know how to config this on it? – Luke Apr 8 '18 at 12:43
27

On Windows Server 2012 R2:

Local Security Policy -> Local Policies\Security Options

Microsoft Network server: Amount of idle time required before suspending session

15 minutes is default.

| improve this answer | |
  • 3
    For us non-admins start-->run: secpol.msc to edit Local Security Policy. Thanks Niels this worked for me. :) – Brian Aug 7 '15 at 10:17
  • 1
    You can also go to Control Panel > Administrative Tools > Local Security Policy ;) – user2464083 Dec 31 '15 at 17:21
  • This seems to just disconnect the session, does not log off – vanderwyst Mar 8 '19 at 23:35
  • This didn't stop my RDP connection from kicking me out and logging me off when debugging. – justdan23 Jul 15 '19 at 16:02
0

It would seem that the policy for the RDP sessions are set to disconnect after a period of time (15 minutes) Do you manage the Windows 2012 server?

If it is another department, contact them as this may be a policy that they apply at the domain level.

Also note they may wish this disconnect to happen to avoid too many sessions or someone accidentally making a change.

| improve this answer | |
  • Someone else installed the system and he's not available anymore. So, I'm now managing it. The server is really simple and only have 5 remote desktop connections. – Speccy Feb 28 '13 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.