14

There's an old joke that English will be the language of Heaven, because Americans won't learn foreign languages. Microsoft seems to have internalized this joke...

I am an American English speaker; I occasionally need to type in Russian, so I install the Russian Phonetic Student (aka "yasherty") keyboard and occasionally switch to it. As soon as I install it, all of my printers default to A4 paper instead of Letter. Since the two sizes are pretty close, it's usually not a problem - but labels (actually, anything with narrow margins) don't work properly, and various documents insist on being loaded into the manual-feed tray of whatever printer I happen to be using. (It took me a while to understand why that was happening - that was how I initially discovered that my paper size had changed.)

I can go to Properties for each installed printer, and in Preferences - Paper/Quality - Advanced I can set the Paper Size for each tray the printer supports. That fixes the problem. However, if I install another printer - or if PDFCreator updates itself - I have to do it again.

This happens in Windows XP, Vista, 7, and 8 (I never installed an alternate keyboard before XP); it happens with the Russian Phonetic, Russian Standard, Russian Typewriter, and various French keyboard layouts. My Region and/or Locale settings (depending on the Windows version) have always been United States/English - but as soon as I indicate that I might speak another language, Windows apparently decides I'm European, and sets my paper size accordingly.

4

I do not know if this will solve your issue after keyboard changes. But I've been having to change printer properties every time I print, from A4 defaults, and finally think I have fixed it.

To change the printer defaults, you have to be in Control Panel, Devices and Printers. Right click and select -->Printing Preferences. Adjust the Paper size to Letter, then click the button -->Default. Click apply. The settings on the default printer seem to now have picked up on the other printers (Windows 10.)

(As a matter of reference, I am in Canada, not Europe, and A4 keeps showing up)

2
  • This worked for me, on an HP printer. – Laurent Jun 26 '16 at 5:45
  • Using Windows 10 and a HP LaserJet, there is no such option. – David Balažic Aug 25 '20 at 10:16
3

Windows decides the default paper size depending on "control panel -> Region and Language -> Formats -> Format:" setting.

Change Format to "English (United states)", then when you install a printer it will default to paper size Letter. Change it to some European format like "Dutch (Netherlands)" and it will default to A4.

2
  • 2
    It's been a while since I had to set up a new machine and add an alternate keyboard, so I can't test this immediately - but I'm fairly certain this is not correct. My date/time/currency formats do NOT change; only the default paper size. Once again, the circumstances of my question are: start with a standard US-English factory-default setup; add an alternate (NOT primary) keyboard in some other language. The default paper size changes; date/time/currency do not. – MT_Head Oct 23 '14 at 16:59
  • I have the option at "English (Slovenia)" (Windows 10, factory setting) yet it still defaults to Letter instead of A4. – David Balažic Aug 25 '20 at 10:24
2

I might be a little late for the party, I have Windows 10, and I ran into this problem from the opposite side. I try to have my computer language English, and my locale Hungarian, and that went ok, until I messed with the keyboard languages. In the language list, the one that comes first will be the language of your system, apps, etc and also the default keyboard language.

Since I wanted the default keyboard language Hungarian, but the apps language English, I had to search intensively for a solution, and I found one - in the Settings app > Devices > Typing > Advanced Keyboard Settings > Override for default input method to Hungarian (in your case Russian) while in > Time & Language > Language I keep my preferred language list as 1. English and 2. Hungarian

Now it works as I expected, except that it defaults to Letter size in printing preferences (I want A4), that's how I ended up here.

2

A simple powershell script can be used to change the print settings for all printers with relative ease:

get-printer | ForEach-Object  {set-printconfiguration -printerobject $_ -Papersize "Legal" }
2

Ok, i had a similar problem here and solved it with a somewhat hidden reg key in windows, at least in the recent Win10 (v2004). Take a look at the reg key

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CommonGlobUserSettings\Control Panel\International

There is a key iPaperSize with a numeric value. This value comes from the wingdi.h constants for the paper forms letter, A4 and so on. An excerpt from this file is:

  • #define DMPAPER_LETTER 1
  • ...
  • #define DMPAPER_A4 9
  • ...

Writing one of these values into the mentioned regkey results in creating new printers with this paper size, at least for previously unknowns printers.
My region settings are modified from the defaults as i prefer an english OS with german settings for date, currency and such.

Update: Also it must pay attention that the regkey can also be in the following user-dependant location:

Computer\HKEY_CURRENT_USER\Control Panel\International

If this is the case these settings will take precendence to the one in the HKLM.

1
  • This worked. None of the other solutions are even valid in Windows 10. There is no region or "default" printer setting for Google Chrome save as PDF. – pablorenato Oct 19 '20 at 4:29
0

I've not done this myself so apologies if it doesn't quite work out. However...

I think that you need to look at the international settings. You should be able to add the alternative keyboard to your US settings without it changing everything else. I think that what is happening is that you are changing locale's and that brings with it changes to date displays, currency, etc. If you can live without those things then manually adding the Russian keyboard to your US settings should work.

2
  • 1
    As I stated in my last paragraph above, my locale (it's called "Region" in Windows 8, by the way) has never changed from US English. I didn't want to shoot down your answer without checking, so I just now verified: everything (that I can directly configure, that is!) is standard for the US: currency symbol, decimal formats, etc. Adding a keyboard in a different language doesn't change any of that, as long as you add it as an alternative and not the primary. But still, as soon as you add the alternative keyboard, your paper size will default to A4. – MT_Head Mar 3 '13 at 2:57
  • OK, thanks @MT_Head. I did say I wasn't sure if I was right. I'll leave it for other peoples reference though unless you would prefer I removed it. – Julian Knight Mar 3 '13 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.