My installation of Ubuntu 12.10 won't boot any more. I do not know what caused it to fail; the last time I used Ubuntu I installed Dropbox and the disk space ran a little low. After that I booted Windows, and ever since Ubuntu is stuck on the splash screen when booting. I have tried running boot repair, but that didn't help.

The results from boot repair is available here. I have tried removing the Dropbox folder as well to free up some space, but with the same result. It may be worth noting is that the splash screen's five dots isn't animating as they usually do during boot.

  • Try booting another (older) kernel in the GRUB list when booting Ubuntu, if you get that far. Perhaps the kernel got upgraded, and the latest kernel that is made the default directly has some issue with your system. (Funny that around line 625 it seems that there is a boot loader on /dev/sda3 that consists of a TripAdvisor review. That can't be good! :-D If it is not a bootable partition anyway, probably it is just a weird artifact of some sort, though.) – Daniel Andersson Mar 2 '13 at 13:27
  • Thank you for your reply :) Tried all way down to 3.5.0-17-generic but with the same issue. I repartitioned my drive a while ago to give Ubuntu more space, maybe that caused an extra partition. – Anton Gildebrand Mar 2 '13 at 13:34
  • While Ubuntu is booting up with a splash screen, hit ESC to see what's actually going on. Pay close attention to the message flied by. Last time my Ubuntu boot up froze on me, it was because of line about 20 lines before the last message, which says something like "Press S to fix the disk" (or maybe "C", can't recall the details)
  • If you suspect that the extra partition is the problem, try boot up from a Ubuntu Live system. I.e., If it boots fine, then the extra partition is not the problem/cause.
  • And while your Ubuntu Live is booted, try to mount all partitions from your HD, especially the boot partition and the OS partition. Do the mount under 'sudo su -' from the command line, when you can see if anything went wrong, so that you can fix the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.