1

I've had this problem for a while, but have only recently really tested what works and what doesn't, and it's frightfully confusing. Here's my drive situation (Sony Vaio FE890 running ArchLinux):

  • Sony vaio FE-890 optical drive (MATSHITA cd/dvd read/writer)
  • fails to burn anything (cd or dvd)
  • fails to mount data CDs
  • fails to mount data DVDs
  • successfully plays video DVDs (doesn't require mounting)
  • no idea if it'll play an audio CD (who even has those anymore?)

A long time ago (circa a year and a half) it had similar issues (at the time, I just noticed burning CDs failed) I took the drive apart, tinkered a little and put it back together again and it worked perfectly. I tried the same approach again this time and no dice. The problem hasn't bothered me much as with a decent net connection and flash drives, optical media aren't all that necessary, but I find myself needing to read data DVDs (OS installation media), no flash drives and a tenuous connection to the internet

Trying to mount a CD or DVD then running dmesg returns this:

cdrom: This disc doesn't have any tracks I recognize!
attempt to access beyond end of device
sr0: rw=0, want=68, limit=4
attempt to access beyond end of device
sr0: rw=0, want=1028, limit=4
attempt to access beyond end of device
sr0: rw=0, want=2052, limit=4
UDF-fs: No anchor found
UDF-fs: No partition found (1)
attempt to access beyond end of device
sr0: rw=0, want=68, limit=4
isofs_fill_super: bread failed, dev=sr0, iso_blknum=16, block=16

The fact that DVD videos play just fine stumps me. It means that the reading is happening just fine, but just the mounting fails. However, I doubt it's a driver/software problem as it also fails to boot from bootable CD/DVDs

Any ideas/thoughts/eureka's?

Thanks! -Mala

1

It is probably just end of it's life.

I see this sort of random behaviour all the time in slim line optical drives (desktop as well, but a lot less common).

Usually I see that it can read from produced cd's and dvd's but home burnt r's and rw's fail... but, there is no one answer fits all and it is always random as you have said above.

Get another drive and swap over all the housings (that was it costs £20 instead of Sony's £200!), or if you have a spare computer - use that, convert to ISO and mount it on your machine.

0

It's probably an alignment issue. When you write "video DVDs" you probably mean "pressed" DVDs, which are optically slightly different from "burned" DVDs like the ones you can make yourself, and the specific hardware failure you're experiencing is stopping one, but not the other.

Agree with Wil--just go ahead and get another drive. They're cheap now.

  • actually no - as long as i don't need to mount the drive, dvd reading works fine. This means pressed or burned video dvds work fine, pressed or burned data dvds fail. All CD functions fail. Strange, huh? – Mala Nov 25 '09 at 9:10
  • Not actually possible. Really, it isn't. See, video DVDs are just data DVDs with specific files on them in specific directories--there's no difference at the dye-on-plastic level at all. I have no idea why you're seeing this seemingly-impossible behavior. – CarlF Nov 25 '09 at 14:11

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.