Google chrome keeps refreshing the page to Google.com (my home page). Even when I get a chance to go to a different site before it restarts it will redirect me from the new page back to the home page. From looking at other reports of this incident I am not sure if it is the same as others reporting a similar problem. I have ZERO extensions or anything added to the basic chrome browser as it comes out of the box. I have reinstalled Chrome and it does the same thing. I already have issues with Chrome constantly needing to be manually fixed whenever there is an update to adobe flash and disabling one of the flash players. That was bad enough, but this is getting to the point that I am considering removing google chrome completely and never using again. I'll use IE, which I feel is an inferior product, as well as being much slower. HOWEVER, it does not have any of these problems that seem to constantly arise from the use of Chrome. Can't really see any reason to keep wasting time as every month or two I have to go on the Internet to try and figure out why it isnt working anymore... again...

2 Answers 2


This was happening to me too. I was able to avoid the refreshes by turning off "instant" search under google chrome settings.

  • For me it started after Chrome prompted me to use google.co.uk instead of google.com while traveling. As an added twist: on Mac OS I could not browse anywhere, since it would refresh within a second. I could browse using an incognito window... but attempting to open chrome://settings in the incognito window instead opened the settings in the other Chrome window for a half second, before redirecting to google.co.uk. I was able to finally get around it by turning of my network connection.
    – mdahlman
    Mar 22, 2013 at 20:11
  • Same here. I as traveling when it happened.
    – mga911
    Mar 23, 2013 at 7:02

This may be because of a malware... There is a tool called "Chrome cleanup tool”. This tool scans and removes the malicious software which causes problems with chrome. It also resets your chrome settings to default.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .