I get weird behavior with Windows 8, on several computers (HP and Dell laptops, and a tower PC) with different Logitech keyboards (K800, G15, and G510): right after the Windows installation, everything works fine. But after the first batch of updates, the media keys (sound +/-, backward/forward, play/pause) donn't work anymore.

Note that I've never installed any driver for my Logitech hardware (and everything has always worked fine so far). I performed the test with the tower PC and the K800 keyboard, but it didn't change anything.


Solution found on this Logitech forum's thread: G510, Media Keys and Windows 8

It looks like one of the first updates messes up the HID (Human Interface Device) service activation. In order to fix it, follow these steps:

  1. Press Windows+X and select "Computer management".
  2. At the left, under "computer management", you find "Services and Applications". Open it and select "Services".
  3. Search for a service named Human Interface Device Access (or something VERY similiar).
  4. Once found, check the status. If the value is not "Started", start it.
  5. To make sure it will be on also in the future, check the Startup Type value. If not "Automatic", right click it, and select properties.
  6. Under the tab "General", change the Startup type to Automatic.
  7. Apply and close.

enter image description here

  • 2
    Works for other keyboards and media remotes! Thanks
    – joshkrz
    Jul 22 '13 at 23:01
  • 2
    I tried this, but it only works when the Services windows is the selected window, or when one of two others are (Gigabyte Force, Curse Voice). Any thoughts?
    – Cora
    Jul 16 '14 at 2:57
  • 1
    For everyone using a German version of Windows: The Service is called "Zugriff auf Eingabegeräte", so don't try to find it under "Eingabegeräte" or "Human Interface Device" where you'd expect it. It's hiding right down at the bottom of the list.
    – BlaM
    Nov 13 '14 at 8:19
  • 4
    @latata in my case the problem was the Google Play Music plugin for Google Chrome. It overrides the media keys in a really funny way.
    – Cora
    Jan 31 '15 at 19:17
  • 1
    @DarkWolffe thanks a lot! I turned off Google Play Music plugin and now it works!
    – latata
    Feb 2 '15 at 12:29

@Anto's answer didn't work for me on Windows 10 iTunes 12 but this did:


Not the answer you're looking for? Browse other questions tagged or ask your own question.